470,602 Members | 1,572 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,602 developers. It's quick & easy.

Finding an Installable ISAM

I received a "Could Not Find Installable ISAM" error (#3170) when using
Docmd.TransferDatabase to export a table from one database to another -

Set wrkDefault = DBEngine.Workspaces(0)
DBEngine.CreateDatabase strFileName, "c:\Database\"
DoCmd.TransferDatabase acExport, "Microsoft Access", _
"C:\database" & strFileName, acTable, "tblBatchTEMP", _
"tblBatchARCHIVE"

I suspect this is due to having just upgraded my version of Access2000 with
Update Rollup1 for Windows2000 SP4.

According to the Microsoft Knowledgebase
(http://support.microsoft.com/default...;en-us;209805), I probably
have a dll file containing the Import/Export ISAM for Microsoft Jet. It
lists -
Msrd2x40.dll for the ISAM for import/exporting for Microsoft Jet 2.0
Msrd3x40.dll for the ISAM for import/exporting for Microsoft Jet 3.0

I assumed there should be a file called Msrd4x40.dll for the ISAM for
import/exporting for Microsoft Jet 4.0.....but I don't have one. Am I
assuming correctly that this is the problem?
And, if so.......
Does anyone know where I can download this from? Is that probably all I
need to do (and the requisite REGISTRY KEY adjustments as described in the
KnowledgeBase solution for this error).

Thanks.

Andi Plotsky


Nov 13 '05 #1
2 7031
The second parameter to the CreateDatabase method takes a locale parameter
which refers to the collating order for the database. If you correct this
parameter, you will not receive the 3170 error. Below is an example that
works without error in Access 2003:

Dim strFileName As String
Dim wrkDefault As Workspace

strFileName = "H:\Documents and Settings\david\My Documents\db4.mdb"
Set wrkDefault = DBEngine.Workspaces(0)
DBEngine.CreateDatabase strFileName, dbLangGeneral
DoCmd.TransferDatabase acExport, "Microsoft Access", _
"H:\Documents and Settings\david\My Documents\db4.mdb", acTable,
"Test1", _
"Test1ARCHIVE"

--
David Lloyd
MCSD .NET
http://LemingtonConsulting.com

This response is supplied "as is" without any representations or warranties.
"DBQueen" <ir******@bellsouth.net> wrote in message
news:E_*******************@bignews5.bellsouth.net. ..
I received a "Could Not Find Installable ISAM" error (#3170) when using
Docmd.TransferDatabase to export a table from one database to another -

Set wrkDefault = DBEngine.Workspaces(0)
DBEngine.CreateDatabase strFileName, "c:\Database\"
DoCmd.TransferDatabase acExport, "Microsoft Access", _
"C:\database" & strFileName, acTable, "tblBatchTEMP", _
"tblBatchARCHIVE"

I suspect this is due to having just upgraded my version of Access2000 with
Update Rollup1 for Windows2000 SP4.

According to the Microsoft Knowledgebase
(http://support.microsoft.com/default...;en-us;209805), I probably
have a dll file containing the Import/Export ISAM for Microsoft Jet. It
lists -
Msrd2x40.dll for the ISAM for import/exporting for Microsoft Jet 2.0
Msrd3x40.dll for the ISAM for import/exporting for Microsoft Jet 3.0

I assumed there should be a file called Msrd4x40.dll for the ISAM for
import/exporting for Microsoft Jet 4.0.....but I don't have one. Am I
assuming correctly that this is the problem?
And, if so.......
Does anyone know where I can download this from? Is that probably all I
need to do (and the requisite REGISTRY KEY adjustments as described in the
KnowledgeBase solution for this error).

Thanks.

Andi Plotsky

Nov 13 '05 #2
That did it...thanks so much for your help!

Andi Plotsky

"David Lloyd" <Da***@NoSpamPlease.com> wrote in message
news:lp*****************@bignews4.bellsouth.net...
The second parameter to the CreateDatabase method takes a locale parameter
which refers to the collating order for the database. If you correct this
parameter, you will not receive the 3170 error. Below is an example that
works without error in Access 2003:

Dim strFileName As String
Dim wrkDefault As Workspace

strFileName = "H:\Documents and Settings\david\My Documents\db4.mdb"
Set wrkDefault = DBEngine.Workspaces(0)
DBEngine.CreateDatabase strFileName, dbLangGeneral
DoCmd.TransferDatabase acExport, "Microsoft Access", _
"H:\Documents and Settings\david\My Documents\db4.mdb", acTable,
"Test1", _
"Test1ARCHIVE"

--
David Lloyd
MCSD .NET
http://LemingtonConsulting.com

This response is supplied "as is" without any representations or warranties.

"DBQueen" <ir******@bellsouth.net> wrote in message
news:E_*******************@bignews5.bellsouth.net. ..
I received a "Could Not Find Installable ISAM" error (#3170) when using
Docmd.TransferDatabase to export a table from one database to another -

Set wrkDefault = DBEngine.Workspaces(0)
DBEngine.CreateDatabase strFileName, "c:\Database\"
DoCmd.TransferDatabase acExport, "Microsoft Access", _
"C:\database" & strFileName, acTable, "tblBatchTEMP", _
"tblBatchARCHIVE"

I suspect this is due to having just upgraded my version of Access2000 with Update Rollup1 for Windows2000 SP4.

According to the Microsoft Knowledgebase
(http://support.microsoft.com/default...;en-us;209805), I probably have a dll file containing the Import/Export ISAM for Microsoft Jet. It
lists -
Msrd2x40.dll for the ISAM for import/exporting for Microsoft Jet 2.0
Msrd3x40.dll for the ISAM for import/exporting for Microsoft Jet 3.0

I assumed there should be a file called Msrd4x40.dll for the ISAM for
import/exporting for Microsoft Jet 4.0.....but I don't have one. Am I
assuming correctly that this is the problem?
And, if so.......
Does anyone know where I can download this from? Is that probably all I
need to do (and the requisite REGISTRY KEY adjustments as described in the
KnowledgeBase solution for this error).

Thanks.

Andi Plotsky


Nov 13 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by Brent | last post: by
1 post views Thread by Guly | last post: by
6 posts views Thread by Robert Lawson | last post: by
2 posts views Thread by Henrik | last post: by
1 post views Thread by Anatoly Kurilin | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.