By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,133 Members | 1,092 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,133 IT Pros & Developers. It's quick & easy.

Enter Key Behaviour

P: n/a
AccessXP

When I use the wizard to create a form, all the textboxes are created with
the Enter Key Behaviour of "New Line In Field". When I create the form
manually the Enter Key Behaviour is "Default". "New Line In Field" is
undesirable because when I go to enter data in the field and then ptess
<Enter>, rather than go to the next field, a carriage return is entered in
the textbox and as the property says, Access goes to a new line in the
field. How do I get the wizard to make the Enter Key Behaviour "Default" so
when I press <Enter> I go to the next field?

The Enter Key Behaviour property is in properties under the Other tab.

Thank you!

Susan
Nov 13 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
The normal bivouac is that for regular fields, you get "default".

for memo fields, you get "New line in field". This decision by the wizard
makes sense to me since when you use a memo field, you are likely to have a
lot of text, and likely multiple lines of text...

Now, in your case, is it possible that these fields are of a type memo
field? (this likely very wrong on your case...as you do NOT want to use a
memo field unless necessary). Memo fields can't be indexed for example...

I would check your field types in the table design, as memo fields always
defaulted new line when created by the wizard....

--
Albert D. Kallal (Access MVP)
Edmonton, Alberta Canada
pl*****************@msn.com
http://www.members.shaw.ca/AlbertKallal
Nov 13 '05 #2

P: n/a
Thanks for your response!

I'm not using memo fields but your response led me to the answer. After a
little experimenting, here is what I found. You can set the default field
size for text data type under Tools - Options - Tables. Of course you can
set the field size in tables design view to whatever you want. If you set
the default to anything over 60 in Tools - Options - Tables and leave it at
that in your text fields, when you use the form wizard it sets the Enter Key
Behaviour to "New Line In Field". Or if you set the default in Tools -
Options -Tables to under 60 but in table design you set the field size to
anything over 60 for text data types, again the form wizard sets the Enter
Key Behaviour to "New Line In Field".

Now you may not readily notice the effect this has in a form created by the
form wizard! If during the creation of the form you create a textbox of say
height .1667 and you tab out of the textbox during testing, you see no
effect. However you give the app to a user and for whatever reason he makes
an entry in the textbox then presses the <Enter> key, his entry disappears.
He then comes back to you complaining of this strange behaviour. If you are
like me (before I got your response and did some investigating) you scratch
your head and wonder what is going on. Thanks to you I discovered that
pressing the <Enter> key added a carriage return and the original entry
scrolled off the screen to make room for the continuation of the user's data
entry just the same as if he had pressed Control - Enter. This can be a
"Gotcha" if you are not aware that this will happen!!

Susan
"Albert D. Kallal" <ka****@msn.com> wrote in message
news:tAxOe.290227$s54.176595@pd7tw2no...
The normal bivouac is that for regular fields, you get "default".

for memo fields, you get "New line in field". This decision by the wizard
makes sense to me since when you use a memo field, you are likely to have
a lot of text, and likely multiple lines of text...

Now, in your case, is it possible that these fields are of a type memo
field? (this likely very wrong on your case...as you do NOT want to use a
memo field unless necessary). Memo fields can't be indexed for example...

I would check your field types in the table design, as memo fields always
defaulted new line when created by the wizard....

--
Albert D. Kallal (Access MVP)
Edmonton, Alberta Canada
pl*****************@msn.com
http://www.members.shaw.ca/AlbertKallal

Nov 13 '05 #3

P: n/a
"Susan" <no*******@me.please> wrote in message
news:4z*************@newsread3.news.atl.earthlink. net...
Thanks for your response!


And, a very nice thank you back for sharing your discovery....

Now we know!!
--
Albert D. Kallal (Access MVP)
Edmonton, Alberta Canada
pl*****************@msn.com
http://www.members.shaw.ca/AlbertKallal
Nov 13 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.