By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,904 Members | 925 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,904 IT Pros & Developers. It's quick & easy.

Hidden fields become visible when filter by form--how to prevent

P: n/a
NTE
Access 2000,

My application has a main form that the users interact with. There are
2 hidden fields.

When they select "filter by form" from the menu, the hidden fields
become visble.

Is there a way to prevent this, or to reset them to visible=false?

It did not appear that any of the events would have the correct timing.

Thanks,
Nicole

Nov 13 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
On 18 Aug 2005 12:02:36 -0700, NTE wrote:
Access 2000,

My application has a main form that the users interact with. There are
2 hidden fields.

When they select "filter by form" from the menu, the hidden fields
become visble.

Is there a way to prevent this, or to reset them to visible=false?

It did not appear that any of the events would have the correct timing.

Thanks,
Nicole


They do not become visible for me (if I try what I think you mean).
Perhaps there is code in the Form's ApplyFilter event that turns them
visible.
Perhaps try, in the ApplyFilter event:
Me![ControlName1].Visible = False
Me![ControlName2].Visible = False
etc.

--
Fred
Please only reply to this newsgroup.
I do not reply to personal email.
Nov 13 '05 #2

P: n/a
NTE
Fred,

thank you for the response. I did try what you suggested. However,
even without that code in the ApplyFilter event, the fields return to
invisible when the user chooses the apply filter tool and gets their
results. So this is the series of events:

1. main form is opened, hidden fields are not visible (controls visible
property was set to no at design time)
2. user chooses filter by form tool from custom menu (which is just a
subset of the regular menu)
3. Form switches to filter mode, hidden fields become visible (and are
editable!, where at design time I had them set to locked)
4. One of the non-hidden fields is used for the filter query, and apply
filter is choosen
5. The view switches back to the normal form (filtered), and the hidden
fields are now no longer visible.

So, I'm not sure if there is another place where I can control
visibility. I thought that by making controls not visible at design
time that they would never be visible...........
Nicole

Nov 13 '05 #3

P: n/a
"NTE" <ne******@labyrinth.net> wrote in message
news:11**********************@g47g2000cwa.googlegr oups.com...
Access 2000,

My application has a main form that the users interact with. There are
2 hidden fields.

When they select "filter by form" from the menu, the hidden fields
become visble.

Is there a way to prevent this, or to reset them to visible=false?

It did not appear that any of the events would have the correct timing.

Thanks,
Nicole


Nicole,
I wonder if selecting "Filter By Form" somehow triggers datasheet view.
There is another property called columnhidden. On some forms, I allow my
users to freely switch back and forth between Form view and Datasheet view.
So I always set visibility options by setting both properties:

Me.txtControl.Visible = False
Me.txtControl.ColumnHidden = True

See if this corrects your problem.
Fred Zuckerman
Nov 13 '05 #4

P: n/a
NTE
Hi Fred,

thank you for the reply. And I will look into what you have suggested.

After thinking about it for a few hours, and wondering why FredG above
could not duplicate the problem, I realized I left out one important
thing. The hidden controls are on a tab control.

I tried a form with no tab control and did not have the problem.

So, it appears to be related to filtering on a tab control. I'll
search the newsgroup for that topic, and if you have any insight I
would appreciate hearing from you. My apologies for the oversight.....

Nicole

Nov 13 '05 #5

P: n/a
NTE
SOLVED MY OWN PROBLEM.

I set the enabled property of the controls to "no" (or false) and now
they do not show up when the form goes into filter by form mode.

Sorry for the trouble, appreciate the effort.

Nicole

Nov 13 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.