By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,479 Members | 2,239 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,479 IT Pros & Developers. It's quick & easy.

Can't save decimal numbers

P: n/a
Ok, I know this sounds bizarre and I regret to say it has me baffled. New
decimal fields in tables will accept entry of decimal numbers but
immediately change same into integers.

Can someone please tell me what incredibly silly thing I'm doing to cause
this???

Thanks
Nov 13 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
You probably have an integer field.
You have to both set the type to numerical, and the subtype to either
Single or Double (precision floating point). Numerical defaults to Long
(integer)

lo*****@internet.com wrote:
Ok, I know this sounds bizarre and I regret to say it has me baffled. New
decimal fields in tables will accept entry of decimal numbers but
immediately change same into integers.

Can someone please tell me what incredibly silly thing I'm doing to cause
this???

Thanks


--
Bas Cost Budde, Holland
http://www.heuveltop.nl/BasCB/msac_index.html

Nov 13 '05 #2

P: n/a
On Fri, 24 Jun 2005 08:38:08 +0100, Bas Cost Budde
<b.*********@heuvelqop.nl> wrote:
You probably have an integer field.
You have to both set the type to numerical, and the subtype to either
Single or Double (precision floating point). Numerical defaults to Long
(integer)
Thanks for your reply but the settings areas follows:

Data Type: Number

On the General Tab:
Field Size: Decimal
Format: General Number or Fixed or Percent
Precision: 18
Scale: 0
Decimal Places: 2

All numerical entries with decimals are changed to integers.

Make sense?
lo*****@internet.com wrote:
Ok, I know this sounds bizarre and I regret to say it has me baffled. New
decimal fields in tables will accept entry of decimal numbers but
immediately change same into integers.

Can someone please tell me what incredibly silly thing I'm doing to cause
this???

Thanks


Nov 13 '05 #3

P: n/a
Like Bas says...

Change the decimal Field Size to Double and all should work loverly.

Rob.

Nov 13 '05 #4

P: n/a
Margaret and Loren Block wrote:
On Fri, 24 Jun 2005 08:38:08 +0100, Bas Cost Budde
<b.*********@heuvelqop.nl> wrote:
You probably have an integer field.
You have to both set the type to numerical, and the subtype to either
Single or Double (precision floating point). Numerical defaults to
Long (integer)

Thanks for your reply but the settings areas follows:

Data Type: Number

On the General Tab:
Field Size: Decimal
Format: General Number or Fixed or Percent
Precision: 18
Scale: 0
Decimal Places: 2

All numerical entries with decimals are changed to integers.

Make sense?


Scale = 0 means no decimal places.

--
I don't check the Email account attached
to this message. Send instead to...
RBrandt at Hunter dot com
Nov 13 '05 #5

P: n/a
On 24 Jun 2005 07:54:22 -0700, "dkintheuk" <rm*******@firenet.uk.com>
wrote:
Like Bas says...

Change the decimal Field Size to Double and all should work loverly.

Rob.

The nomenclature sure seems odd but changing the Field Size from Decimal to
Double and Format to General Number did it.

Thanks very much.
Nov 13 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.