By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,648 Members | 1,654 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,648 IT Pros & Developers. It's quick & easy.

A97: Importing AutoExec macro from Access 2.0

P: n/a
MLH
I have problems getting the CTRL-d, CTRL-w and other 'hotkey combo'
assignments to work in Access 97. I just imported the autoexec macro
directly from Access 2.0, so its no surprise.

Some are really simple, though... For instance, CTRL-w should just
launch ScreenDump(). I can run the FN by calling it this way...
dim y as variant
y = screendump()

But I cannot get the CTRL-w to launch it the way it did in Access 2.0.

Ideas?
Nov 13 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
MLH
BIG OOPS...

I'm really concerned with the AutoKeys macro...
I inadvertently referred to it as the AutoExec macro
in the main thread. Sorry. AutoKeys is what I'm trying
to make work.
Nov 13 '05 #2

P: n/a
There's not really enough info here to help with any degree of
certainty. Here's how it should be.
Your macro name (you may need to go View...Macro Names to see this
column) should be: ^w
Your action should be: RunCode
Function Name: ScreenDump() (not =Screendump or anything like that).
The name of the macro object in the database window should be: AutoKeys
(not to be confused with the macro name column in macro design)

Close the database and re-open it to activate the autokeys macro.

It should work.

Nov 13 '05 #3

P: n/a
MLH
I did all that with the imported macro.
I think I'll blow it away, recreate an
AutoKeys macro from scratch (and
from within Access 97) and try it again.

Everything you said was right. That's
how I had it set up in Access 2.0 and
it "looked" like it was just the same
way after the import.

Will fill U in.

Nov 13 '05 #4

P: n/a
MLH
I sure hate to say it, but it definitely does NOT work. I restarted
Access 97 after building the new autokeys macro. I tried setting
macro names of ^4 and ^w. Nothing worked. Something is
awry. Are there any settings that might disable autokeys macro?

There's not really enough info here to help with any degree of
certainty. Here's how it should be.
Your macro name (you may need to go View...Macro Names to see this
column) should be: ^w
Your action should be: RunCode
Function Name: ScreenDump() (not =Screendump or anything like that).
The name of the macro object in the database window should be: AutoKeys
(not to be confused with the macro name column in macro design)

Close the database and re-open it to activate the autokeys macro.

It should work.


Nov 13 '05 #5

P: n/a
MLH
I even set up a macro to RunCode on the function
just by calling the macro with the RunMacro method.

It worked just fine.

I don't understand why my macro names in the macro
group (IE, ^a, ^g, +4, etc...) are not causing the macro
code in the named macros inside the autokeys macro
to be invoked. Its a mystery.
Nov 13 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.