By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,709 Members | 2,211 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,709 IT Pros & Developers. It's quick & easy.

Write conflict with subform

P: n/a
I've loked over older messages on this, but haven't found a solution.

I have a datasheet of records, and each record has a subform that can
be viewed with the expand '+' symbol. The subform simply shows
addition fields of the record it is expanded from. I used the subform
control wizard to tell it how to link the records when creating the
subform. There is only one control in the subform that the users can
edit, a textbox. All the other controls are locked. The mainform
datasheet also only has one control that the users can edit, which is a
combobox.

If the user types in the subform texbox, and then makes a selection in
the main form drop down box, then I get the Write conflict message, if
I tell it to save changes and overwrite, then it pops up again, the
only way to get out is to drop the changes.

I've tried various combinations of Me.Dirty = False or RunCmd
acSaveRecord as suggested in older posts regarding this similar issue,
but I seem to have not figured out the right events where I should
place this code.

Workaround:
The only way around this that I've found is after making changes to the
textbox, I must save the record AND then refresh. There is a
RunCommand acCmdRefresh, but I'm not sure what event I should place
this in. I tried putting this in the afterupdate of the textbox on he
subform with and also in the onchange event of the main form combobox,
but it still has a write conflict.

Any help would be appreciated.

Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
It seems the write conflict occurs before the onchange event fire of
the combobox also. Also I need only the individual record to refresh.
the acCmdRefresh command causes the entire form to refresh, and for
some reason it ignores serverfilter which I have set with criteria for
the query to be filtered on.

Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.