By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,638 Members | 2,249 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,638 IT Pros & Developers. It's quick & easy.

lose autonumber property when i link mysql & msaccess

P: n/a


Hi,

I have a question regarding autonumbering . I'm using linked tables between
msql and MS Access. Quite a few linked tables exist with relationships. The
auto increment fields once linked loose thier autonumber property and come
up as numbers.

I have developed a form interface and when I press the next record the next
number does not come as the autonumber property has been lost. Thier are
quite a few relationships with linked tables to the mysql database and I
need the primary numbers of those tables within the forms to appear
automatically.

I would really appreciate you help with this problem.

Looking forward to hearing from you.

Smriti
Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Thu, 28 Apr 2005 20:40:57 GMT, "Smriti Dev" <sm********@utoronto.ca> wrote:


Hi,

I have a question regarding autonumbering . I'm using linked tables between
msql and MS Access. Quite a few linked tables exist with relationships. The
auto increment fields once linked loose thier autonumber property and come
up as numbers.
Access is not able to tell teh difference between a column with autonumber and
one without unless it's an Access table. The server should still generate the
number, though.
I have developed a form interface and when I press the next record the next
number does not come as the autonumber property has been lost. Thier are
quite a few relationships with linked tables to the mysql database and I
need the primary numbers of those tables within the forms to appear
automatically.
The server generates the number when the record is saved, and Access can't see
it until after that. Access should retrieve the number after you save the
record - at least that works with the MS SQL Server and PostgreSQL back-ends
I've used Access with so far.
I would really appreciate you help with this problem.


Do you absolutely need to know the number before you save? If so, you
probably should be generating the number through code rather than having the
database server generate it automatically.
Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.