By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,687 Members | 2,228 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,687 IT Pros & Developers. It's quick & easy.

Find Record Button?

P: n/a
I have been able to set up a Find Record Button on my switchboard to
take me to a form with the correct case number by using a parameter
query and macro.

When I try to run the Find Record button from the macro on the form I
want to find the record in it just sits there and does not run.

Could someone tell me how to fix this? Please be specific as I am new
to Access.

Thanks alot for all the help. I am making alot of progress in learning
this program.

Nov 13 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Not sure I understand your problem. Are you running the "Find Record" macro
from a command button on your form? If not, how?

Look at the command button wizard, and try the wizard built "find record"
option. It may be a better solution than the one you have.
-Ed
"Randy" <ra****@msn.com> wrote in message
news:11*********************@o13g2000cwo.googlegro ups.com...
I have been able to set up a Find Record Button on my switchboard to
take me to a form with the correct case number by using a parameter
query and macro.

When I try to run the Find Record button from the macro on the form I
want to find the record in it just sits there and does not run.

Could someone tell me how to fix this? Please be specific as I am new
to Access.

Thanks alot for all the help. I am making alot of progress in learning
this program.

Nov 13 '05 #2

P: n/a
Ed Robichaud wrote:
Not sure I understand your problem. Are you running the "Find Record" macro from a command button on your form? If not, how?

Look at the command button wizard, and try the wizard built "find record" option. It may be a better solution than the one you have.
-Ed
"Randy" <ra****@msn.com> wrote in message
news:11*********************@o13g2000cwo.googlegro ups.com...
I have been able to set up a Find Record Button on my switchboard to
take me to a form with the correct case number by using a parameter
query and macro.

When I try to run the Find Record button from the macro on the form I want to find the record in it just sits there and does not run.

Could someone tell me how to fix this? Please be specific as I am new to Access.

Thanks alot for all the help. I am making alot of progress in learning this program.

Strasser
It sounds like you have 2 command buttons, one on the switchboard and
one on the form itself (the form which is opened in response to the
switchboard command button).

I don't think you can use exactly the same macro for each of these
buttons.
For the button on the form which opens and displayed data, try using a
copied version of your macro run from the switchboard but change the
macro in one way: insert a "close" macro action (making sure to
complete the arguements at the bottom of the macro design screen, so
Access knows the macro is 1) closing a form and 2) "knows" the specific
name for the form to be closed.

When the button on the form is clicked, the form will close.
The form will immediately then be opened again, redisplaying the
prompt, so the user can respond.

You have to close the form before you can open the form again.

Nov 13 '05 #3

P: n/a
Randy, did you solved your problem? I'm having the exact sameone... if
you read this, please reply to this message with the solution
Nov 13 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.