By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,849 Members | 2,339 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,849 IT Pros & Developers. It's quick & easy.

Graph problems - axis scaling & PDF output

P: n/a
Hitting two problems when running a new report I've created, that
contains a chart/graph. The chart shows three series, two are shown as
lines and one as an area. The data come from three different tables,
using a query of the related tables. There are two y-axes. This is
financial info - showing total contributions to an account and the
current account value on the left axis, and a reference stock index on
the right axis.

Amazingly I've been able to get this to mostly work and look decent,
except for a couple small things:

1. out of a batch of ~70 report pages, most of the charts have the both
the right and left Y-axes scaled from 0 to 100, which is what I want.
But 6 or so have arbitrary scales that don't start at zero - they run
from say 90% to 100% of max value. On some it's scaled this way on both
axes, on others it's just the right Y-axis. Can't find anything in the
data that would explain this.

2. when I print to Acrobat Distiller (ie create a PDF from the report
generated on-screen) it displays everything in the report & chart
correctly except the "area" series on the chart. Instead of showing the
real data, it shows a flat line at about mid-Y-axes. If I print to a
printer it's all fine, just the PDF creates the error. I guess that's
potentially an Acrobat issue.

Anyone hit these kinds of things before?

Access XP, Acrobat 5.0.

-Tad

Nov 13 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
> out of a batch of ~70 report pages, most of the charts have the both
the right and left Y-axes scaled from 0 to 100, which is what I want. But 6 or so have arbitrary scales that don't start at zero


If you always want the scales to be 0 to 100, then you can set that in
the chart options. I.e. open the report in design view, double-click
the chart to bring up that horror known as Microsoft Graph,
double-click the axis in question, and find the tab that has the scale
settings. Uncheck the "auto" boxes and type in the minimum and maximum
values you want. Repeat for the other y axis, save and exit Graph.

(This is all from memory, and I haven't used Access XP yet, so adjust
as necessary.)

The pdf thing sounds like an Acrobat issue. I remember having problems
with Acrobat 5.0 using the wrong colors for charts; I don't think we
ever solved the issue, we just found a different way to do things (not
involving Acrobat). Perhaps a later version of Acrobat would help?

--
HTH,
Martha Palotay
don't google to email

Nov 13 '05 #2

P: n/a
Thanks so much for replying Martha, you're right - I had them set to
autoscale for everything, and by setting the min to 0 on both axes &
unchecking autoscale for that value it cleared it up. Makes sense, one
way to override the autoscale's lower bound is to make it zero [I just
found a section in Walkenbach's book on excel charts that has an
explanation of how the autoscaling works.]

In tinkering - one thing I really just don't get is that worksheet that
sits alongside the graph, and the way values seem to be stored with the
object. When I go into design view, the worksheet is filled with data
from the last time I ran the report, I guess from the last chart
displayed. The design-view chart is displaying that data instead of
being blank. And when I go to format the axes, the autoscale values for
that chart are in all of the boxes on that tab. So when you edit
charts it seems you're working with a template/object that has a short
memory of the last thing it displayed, carried along in that mysterious
worksheet. This graph object is just baffling if you ask me!

RE: acrobat - I think you're right, an upgrade might clear it up. Been
trying to avoid that purchase but maybe it's time...and it could take
forever to dig into the source of that error.

Thanks again, I can live with the output now.

-Tad

Nov 13 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.