By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,105 Members | 1,040 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,105 IT Pros & Developers. It's quick & easy.

Pls help

P: n/a
After create an unbound combo box to find record in Form Header, I
find that when I adding record, first field on "record no(eg.0001)"
will disappear after entry, I continue to fill up all the field, I
can't save that record, and I need to re-entry another "record no(eg.
0002)". When I quit and re-entry to this form, I find 0001 (only have
record no.)& 0002 record there. Please advise how can I solve this
problem. Thank you!
Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
"Apple" <tt*********@yahoo.com.hk> ha scritto nel messaggio
news:55*************************@posting.google.co m...
After create an unbound combo box to find record in Form Header, I
find that when I adding record, first field on "record no(eg.0001)"
will disappear after entry, I continue to fill up all the field, I
can't save that record, and I need to re-entry another "record no(eg.
0002)". When I quit and re-entry to this form, I find 0001 (only have
record no.)& 0002 record there. Please advise how can I solve this
problem. Thank you!


If my english work good on Sunday you need to Requery the Combo
after new entry.

Try on afterUpdate Form's event

Me!YourCombo.Requery

To optimize the requery you can set a Boolean to detect
NewRecord on BeforeUpdate, and Requery only if is True.

Bye
--
@Alex (Alessandro Baraldi)
---------------------------------------------------------------------------
http://www.sitocomune.com/
http://www.mantuanet.it/alessandro.baraldi/
---------------------------------------------------------------------------
Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.