467,877 Members | 1,205 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,877 developers. It's quick & easy.

"You do not have access to the folder ... " message using Access97 on WinXP / WinXP SP2

Hi Folks,

I'm experiencing a problem that seems to be unique to running Access97 on
Windows XP, and seems to be worse on WinXP SP2.

It appears when I'm trying to import a text file.

I'm encountering a "You do not have access to the folder 'C:\Program
Files\ProComm Plus\Download\*.*' See your administrator for access to this
folder." message.

I used to be able to "work around" this by making sure that I changed the
'files of type' from "Microsoft Access" to "Text Files" BEFORE attempting to
open the 'C:\Program Files\...' folder... but that doesn't seem to work
anymore in WinXP SP2 ... I guess that's progress for ya!

It's frustrating as hell, and I'm hoping for the "quick fix" :)

Any ideas ... anyone?

TIA
Don
Nov 13 '05 #1
  • viewed: 2116
Share:
2 Replies
Don Leverton wrote:
Hi Folks,

I'm experiencing a problem that seems to be unique to running Access97 on
Windows XP, and seems to be worse on WinXP SP2.

It appears when I'm trying to import a text file.

I'm encountering a "You do not have access to the folder 'C:\Program
Files\ProComm Plus\Download\*.*' See your administrator for access to this
folder." message.

I used to be able to "work around" this by making sure that I changed the
'files of type' from "Microsoft Access" to "Text Files" BEFORE attempting to
open the 'C:\Program Files\...' folder... but that doesn't seem to work
anymore in WinXP SP2 ... I guess that's progress for ya!

It's frustrating as hell, and I'm hoping for the "quick fix" :)

Any ideas ... anyone?


In an ideal world, the OS and programs are separate from data.

* Download to a different folder if possible.
* check security on those folders.

--
This sig left intentionally blank
Nov 13 '05 #2
Hi Trevor,

Thanks for the suggestions, but that didn't do it either.

Here is the routine that I found that does work. It MUST be done in exactly
this fashion:
1.) Close / Restart Microsoft Access
2.) Open the MDB
3.) From DB window, right click and choose "Import"
3.) Select "Text Files" from the 'Files of Type'
4.) Select "*.PF" (in my case) from the 'File Name'
5.) Navigate to the location of the text file. (C:\Program Files\ProComm
Plus\Download in my case.)
6.) Select the file from the list of matching (*.PF) choices.

If I try to do this in ANY other order (i.e. Step 5 first, then 3,4....) I
get the error message.
If I realize that I have made a mistake in the order of doing this, it is
not just as simple as starting over and doing it again. It requires that I
COMPLETELY exit the entire Access application (not even just close and
re-open the MDB) and start all over again.

As I said earlier... its frustrating as hell!

Now that I have this "figured out", I can move on to figuring out why my
import file, which is supposed to be fixed width, is being displayed as a
single record and 65000 characters wide! I'm sure it has to do with
converting CR's to CRLF's.

Don
"Trevor Best" <no****@besty.org.uk> wrote in message
news:41***********************@news.zen.co.uk...
Don Leverton wrote:
Hi Folks,

I'm experiencing a problem that seems to be unique to running Access97 on
Windows XP, and seems to be worse on WinXP SP2.

It appears when I'm trying to import a text file.

I'm encountering a "You do not have access to the folder 'C:\Program
Files\ProComm Plus\Download\*.*' See your administrator for access to
this folder." message.

I used to be able to "work around" this by making sure that I changed the
'files of type' from "Microsoft Access" to "Text Files" BEFORE attempting
to open the 'C:\Program Files\...' folder... but that doesn't seem to
work anymore in WinXP SP2 ... I guess that's progress for ya!

It's frustrating as hell, and I'm hoping for the "quick fix" :)

Any ideas ... anyone?


In an ideal world, the OS and programs are separate from data.

* Download to a different folder if possible.
* check security on those folders.

--
This sig left intentionally blank

Nov 13 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Loane Sharp | last post: by
2 posts views Thread by Brian | last post: by
reply views Thread by jack112 | last post: by
reply views Thread by MrMoon | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.