By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,148 Members | 765 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,148 IT Pros & Developers. It's quick & easy.

Prevent Autonumber from Appearing in Subform

P: n/a
I have a table that is an autonumber field. This table appears as a
subform in another form. I want the ID# to show in the subform...but I
don't want the (Autonumber) to show at the bottom of the subform.

Is there anyway to prevent the last field in my table that has the ID
(Autonumber) from appearing in the sub?

Thanks!
Chris

Nov 13 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Why not just set its visible property to false?

"Fatz" <cc******@ibtco.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
I have a table that is an autonumber field. This table appears as a
subform in another form. I want the ID# to show in the subform...but I
don't want the (Autonumber) to show at the bottom of the subform.

Is there anyway to prevent the last field in my table that has the ID
(Autonumber) from appearing in the sub?

Thanks!
Chris

Nov 13 '05 #2

P: n/a
jv
If you set the visible property to false, it would make all ID# on a
continuous form invisible. Try experimenting with conditional
formating. Conditional formating effects each record individually.
You can specify that if the Name field is null then change the
forecolor of the ID# field to white ... etc..

Nov 13 '05 #3

P: n/a
Fatz wrote:
I have a table that is an autonumber field. This table appears as a
subform in another form. I want the ID# to show in the subform...but
I don't want the (Autonumber) to show at the bottom of the subform.

Is there anyway to prevent the last field in my table that has the ID
(Autonumber) from appearing in the sub?

Thanks!
Chris


Change the ControlSource for that control.

Instead of...
[FieldName]

use...
=[FieldName]

Make sure the name of the control is not the same as the name of the field.
Nov 13 '05 #4

P: n/a
Chris,

If you include your ID field in your subform as a calculated field
(instead of linking directly to the table field), you'll see the ID's
of the exiting records, but "(AutoNumber)" won't show in the New Record
row. In the properties of the field in the subform, change the Name
property to something else, for example txtID. Then set the Control
Source to:
=[ID]

Jerry

Nov 13 '05 #5

P: n/a
jv
Good trick! Thanks.

Nov 13 '05 #6

P: n/a
Jerry-

Thanks for the help!

Go Raiders...

Chris

Nov 13 '05 #7

P: n/a
Fatz wrote:
I have a table that is an autonumber field. This table appears as a
subform in another form. I want the ID# to show in the subform...but I
don't want the (Autonumber) to show at the bottom of the subform.

Is there anyway to prevent the last field in my table that has the ID
(Autonumber) from appearing in the sub?


Why are you even displaying an autonumber field? If users can see it
then they start asking stupid questions like, "why doesn't it start from
1 on this record?", "why are there gaps in the numbering?". They try to
make sense and meaning of this field when it's sole purpose is to give a
unique ID to a record, no more and no less. It means a lot more to a
computer than a human. Humans shouldn't be alowed to see such things.

--
This sig left intentionally blank
Nov 13 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.