By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,191 Members | 1,064 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,191 IT Pros & Developers. It's quick & easy.

How to open MS Access DB exclusively

P: n/a
When I want to edit a MS Database, I have to run the following command:
"C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE"
"\\Server\Directory\File.mdb" /wrkgrp "\\Server\Directory\secured.mdw"

Meaning I have to run with a mdw file, what will be the command be if I
want to open it exclusively? Even opening from MS access is fine, but I
have no idea how I can tell MS access to use that particular mdw
file...

What I am trying to achieve is open add another report there, but I
also get an error message that I can because I have to open it
exclusively. Another strange thing is when I tried to delete the .ldb
file, it does disappear, but when I refresh it from the window
explorer, it just came back on automatically even nobody is using it.
And the icon appears with a lock there...Why is that? Please help. All
I need to know is how I can create a report as I have no right to...
Thanks in advance. Any help would be greatly appreciated.
Wanda

Nov 13 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
previously wrote:
When I want to edit a MS Database, I have to run the following command:
"C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE"
"\\Server\Directory\File.mdb" /wrkgrp "\\Server\Directory\secured.mdw"


just add /excl to open exclusive (assuming that the security settings
allow you to do that, and to add new reports)

From A2000 onwards you must have exclusive access to the database to make
design changes.
Peter Russell

Nov 13 '05 #2

P: n/a
> exclusively. Another strange thing is when I tried to delete the .ldb
file, it does disappear, but when I refresh it from the window
explorer, it just came back on automatically even nobody is using it.
You don't have permission to delete it. (Or possibly, it is still
locked, but I think the behaviour you have described is when you
don't have permission to delete).

/excl won't work unless you can delete the ldb file.
And the icon appears with a lock there...Why is that? Please help.
That is what the icon is supposed to look like. The LDB file is
a 'lock' file, so the icon includes a little 'lock'.

(david)

<wa*****@rogers.com> wrote in message
news:11********************@c13g2000cwb.googlegrou ps.com... When I want to edit a MS Database, I have to run the following command:
"C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE"
"\\Server\Directory\File.mdb" /wrkgrp "\\Server\Directory\secured.mdw"

Meaning I have to run with a mdw file, what will be the command be if I
want to open it exclusively? Even opening from MS access is fine, but I
have no idea how I can tell MS access to use that particular mdw
file...

What I am trying to achieve is open add another report there, but I
also get an error message that I can because I have to open it
exclusively. Another strange thing is when I tried to delete the .ldb
file, it does disappear, but when I refresh it from the window
explorer, it just came back on automatically even nobody is using it.
And the icon appears with a lock there...Why is that? Please help. All
I need to know is how I can create a report as I have no right to...
Thanks in advance. Any help would be greatly appreciated.
Wanda

Nov 13 '05 #3

P: n/a
The weird thing is when I tried another database, if it is opened, I
can't even delete the ldb file, but this one I can...But then the ldb
file will come back up automatically...Any idea? Is there some setting
there I can change so that I can edit the database (adding a new
report)?

Please help. And thanks in advance.
Wanda

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 13 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.