By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,962 Members | 1,998 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,962 IT Pros & Developers. It's quick & easy.

Landscape switching to portrait

P: n/a
I have a strange situation where one or more landscape reports that I
created in A2000 sometimes come up in portrait mode when opened on an A2002
machine. This phenomenon is intermittent, and most of the time they come up
in landscape. But every once in a while they come up in portrait, and the
person opening them (as well as myself) doesn't have any idea why. Any ideas
regarding this?

Thanks,

Neil
Nov 13 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Unless the change is due to a difference in printers/printer drivers between
the machines, it is probably one of the Name AutoCorrect bugs.

See:
Lost Printer Settings When Name AutoCorrect Is Enabled
at:
http://support.microsoft.com/?id=240826

For some of the other problems caused by Name AutoCorrect, see:
http://members.iinet.net.au/~allenbrowne/bug-03.html
--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Neil Ginsberg" <ne**@nrgconsult.com> wrote in message
news:Gl******************@newsread1.news.pas.earth link.net...
I have a strange situation where one or more landscape reports that I
created in A2000 sometimes come up in portrait mode when opened on an A2002
machine. This phenomenon is intermittent, and most of the time they come up
in landscape. But every once in a while they come up in portrait, and the
person opening them (as well as myself) doesn't have any idea why. Any
ideas regarding this?

Nov 13 '05 #2

P: n/a
Thanks for the note. Regarding the printer driver situation, Access used to
allow you to set the printer to (Default Printer), and would use whatever
was the default printer on whatever machine it was on. Did they change that
in recent versions? I noticed that the reports are set to my default
printer, rather than "(Default Printer)." The other person only notices a
problem when I've modified the reports and send the db back to him.

It must be the printer driver, since I don't think it's the Name AutoCorrect
(since that was supposed to be fixed in an A2000 SP, and he's using A2002,
and I don't have mine turned on). Thus, it must be that something happens on
my end with the printer driver when I modify the reports. Is there a way to
use "(Default Printer)" anymore?

(FWIW, the latest I heard is that not only does it only sometimes open in
portrait; but even when it does open in landscape, it still sometimes prints
in portrait! But once he manually changes it to landscape, it's fine.)

Thanks,

Neil
"Allen Browne" <Al*********@SeeSig.Invalid> wrote in message
news:41***********************@per-qv1-newsreader-01.iinet.net.au...
Unless the change is due to a difference in printers/printer drivers
between the machines, it is probably one of the Name AutoCorrect bugs.

See:
Lost Printer Settings When Name AutoCorrect Is Enabled
at:
http://support.microsoft.com/?id=240826

For some of the other problems caused by Name AutoCorrect, see:
http://members.iinet.net.au/~allenbrowne/bug-03.html
--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Neil Ginsberg" <ne**@nrgconsult.com> wrote in message
news:Gl******************@newsread1.news.pas.earth link.net...
I have a strange situation where one or more landscape reports that I
created in A2000 sometimes come up in portrait mode when opened on an
A2002 machine. This phenomenon is intermittent, and most of the time they
come up in landscape. But every once in a while they come up in portrait,
and the person opening them (as well as myself) doesn't have any idea why.
Any ideas regarding this?


Nov 13 '05 #3

P: n/a
Hi Neil

You can (and should) set the report for "Default Printer".
Open it in design view.
Choose Page Setup from the File menu.
On the Page tab, choose Default Printer.

That should solve the whole issue (unless you have left Name AutoCorrect
enabled).

--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Neil Ginsberg" <ne**@nrgconsult.com> wrote in message
news:Vu******************@newsread1.news.pas.earth link.net...
Thanks for the note. Regarding the printer driver situation, Access used
to allow you to set the printer to (Default Printer), and would use
whatever was the default printer on whatever machine it was on. Did they
change that in recent versions? I noticed that the reports are set to my
default printer, rather than "(Default Printer)." The other person only
notices a problem when I've modified the reports and send the db back to
him.

It must be the printer driver, since I don't think it's the Name
AutoCorrect (since that was supposed to be fixed in an A2000 SP, and he's
using A2002, and I don't have mine turned on). Thus, it must be that
something happens on my end with the printer driver when I modify the
reports. Is there a way to use "(Default Printer)" anymore?

(FWIW, the latest I heard is that not only does it only sometimes open in
portrait; but even when it does open in landscape, it still sometimes
prints in portrait! But once he manually changes it to landscape, it's
fine.)

Thanks,

Neil
"Allen Browne" <Al*********@SeeSig.Invalid> wrote in message
news:41***********************@per-qv1-newsreader-01.iinet.net.au...
Unless the change is due to a difference in printers/printer drivers
between the machines, it is probably one of the Name AutoCorrect bugs.

See:
Lost Printer Settings When Name AutoCorrect Is Enabled
at:
http://support.microsoft.com/?id=240826

For some of the other problems caused by Name AutoCorrect, see:
http://members.iinet.net.au/~allenbrowne/bug-03.html

"Neil Ginsberg" <ne**@nrgconsult.com> wrote in message
news:Gl******************@newsread1.news.pas.earth link.net...
I have a strange situation where one or more landscape reports that I
created in A2000 sometimes come up in portrait mode when opened on an
A2002 machine. This phenomenon is intermittent, and most of the time they
come up in landscape. But every once in a while they come up in portrait,
and the person opening them (as well as myself) doesn't have any idea
why. Any ideas regarding this?

Nov 13 '05 #4

P: n/a
Oh, yeah. Must have had a temporary brain malfunction. I was looking at the
Print dialog box. Yeah, it is set to default printer in page setup. And
since Name AutoCorrect isn't set, can't imagine what it could be.

Neil

"Allen Browne" <Al*********@SeeSig.Invalid> wrote in message
news:41***********************@per-qv1-newsreader-01.iinet.net.au...
Hi Neil

You can (and should) set the report for "Default Printer".
Open it in design view.
Choose Page Setup from the File menu.
On the Page tab, choose Default Printer.

That should solve the whole issue (unless you have left Name AutoCorrect
enabled).

--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Neil Ginsberg" <ne**@nrgconsult.com> wrote in message
news:Vu******************@newsread1.news.pas.earth link.net...
Thanks for the note. Regarding the printer driver situation, Access used
to allow you to set the printer to (Default Printer), and would use
whatever was the default printer on whatever machine it was on. Did they
change that in recent versions? I noticed that the reports are set to my
default printer, rather than "(Default Printer)." The other person only
notices a problem when I've modified the reports and send the db back to
him.

It must be the printer driver, since I don't think it's the Name
AutoCorrect (since that was supposed to be fixed in an A2000 SP, and he's
using A2002, and I don't have mine turned on). Thus, it must be that
something happens on my end with the printer driver when I modify the
reports. Is there a way to use "(Default Printer)" anymore?

(FWIW, the latest I heard is that not only does it only sometimes open in
portrait; but even when it does open in landscape, it still sometimes
prints in portrait! But once he manually changes it to landscape, it's
fine.)

Thanks,

Neil
"Allen Browne" <Al*********@SeeSig.Invalid> wrote in message
news:41***********************@per-qv1-newsreader-01.iinet.net.au...
Unless the change is due to a difference in printers/printer drivers
between the machines, it is probably one of the Name AutoCorrect bugs.

See:
Lost Printer Settings When Name AutoCorrect Is Enabled
at:
http://support.microsoft.com/?id=240826

For some of the other problems caused by Name AutoCorrect, see:
http://members.iinet.net.au/~allenbrowne/bug-03.html

"Neil Ginsberg" <ne**@nrgconsult.com> wrote in message
news:Gl******************@newsread1.news.pas.earth link.net...
I have a strange situation where one or more landscape reports that I
created in A2000 sometimes come up in portrait mode when opened on an
A2002 machine. This phenomenon is intermittent, and most of the time
they come up in landscape. But every once in a while they come up in
portrait, and the person opening them (as well as myself) doesn't have
any idea why. Any ideas regarding this?


Nov 13 '05 #5

P: n/a
Neil Ginsberg wrote:
Oh, yeah. Must have had a temporary brain malfunction. I was looking at the
Print dialog box. Yeah, it is set to default printer in page setup. And
since Name AutoCorrect isn't set, can't imagine what it could be.


An easy shot for me is to suggest that you install the latest service
packs since this may solve the problem but I think I'm referring to
A2000...

--
'-------------------------------
' John Mishefske
'-------------------------------

Nov 13 '05 #6

P: n/a
Deb
I have a client who is also having this problem. Their application is
running in Access XP and they have the problem when they use Canaveral.
Name AutoCorrect isn't set.

We are probably going to change the application so that all Landscape
reports are opened in view mode first. They then show as portrait but
immediately switch views.

Any ideas about this?

Deb
"John Mishefske" <mi****@execpc.com> wrote in message
news:10*************@corp.supernews.com...
Neil Ginsberg wrote:
Oh, yeah. Must have had a temporary brain malfunction. I was looking at the Print dialog box. Yeah, it is set to default printer in page setup. And
since Name AutoCorrect isn't set, can't imagine what it could be.


An easy shot for me is to suggest that you install the latest service
packs since this may solve the problem but I think I'm referring to
A2000...

--
'-------------------------------
' John Mishefske
'-------------------------------

Nov 13 '05 #7

P: n/a
Gosh, that sucks that you have to open them in design mode first and switch
to landscape. I may end up doing the same thing.

The only thing I can think of is that it might have something to do with
that I develop in A2000, but they're using A2002. Perhaps it's a mixed
version thing.

Also, I'm going to install my client's printer driver on my system. Who
knows, maybe when it switches printer drivers (since I make design changes)
something gets screwed up.

It's an intermittent thing with us, so a lot more difficult to troubleshoot.
You may have an easier time resolving it if it happens all the time.

Let me know if you get anything resolved.

Neil
"Deb" <db**********@verizon.net> wrote in message
news:uIl0d.180$ZP.125@trnddc05...
I have a client who is also having this problem. Their application is
running in Access XP and they have the problem when they use Canaveral.
Name AutoCorrect isn't set.

We are probably going to change the application so that all Landscape
reports are opened in view mode first. They then show as portrait but
immediately switch views.

Any ideas about this?

Deb
"John Mishefske" <mi****@execpc.com> wrote in message
news:10*************@corp.supernews.com...
Neil Ginsberg wrote:
> Oh, yeah. Must have had a temporary brain malfunction. I was looking at the > Print dialog box. Yeah, it is set to default printer in page setup. And
> since Name AutoCorrect isn't set, can't imagine what it could be.


An easy shot for me is to suggest that you install the latest service
packs since this may solve the problem but I think I'm referring to
A2000...

--
'-------------------------------
' John Mishefske
'-------------------------------


Nov 13 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.