By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,375 Members | 3,001 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,375 IT Pros & Developers. It's quick & easy.

Importing from secured frontend

P: n/a
All,
As you can see below, I have had problems with inquisitive souls looking
at data they shouldn't be. I though disabling the ability to create new
databases using my workgroup would stop this but it doesn't. All they have
to do now is create a new database using the default wrkgroup, close it and
then open it again whilst joined to my workgroup and they can import again.
Can someone please help me stop these people importing from the FE or BE?

Many thanks,

Mark

"MacDermott" <ma********@nospam.com> wrote in message
news:6D*****************@newsread3.news.atl.earthl ink.net...
Do you have a reference to DAO?
From a code window, click Tools - References.
In the box that comes up, check Microsoft DAO Library.
Be sure to exit by using the OK button.

HTH

"Mark" <ma*********@ntlworld.com> wrote in message
news:iz************@newsfe2-gui.ntli.net...
Hi All,
After countless hours of searching, I think I have found a solution
to
my problem from the Microsoft site (
http://support.microsoft.com/?kbid=210329 ). What is suggested is that I
disable the ability to create a new database when using my workgroup. As

the
"inquisitive" person needs to create the database from within my
workgroup
to have permission to import, this seems like the perfect solution.
However, my programming skills are still in their infant stages and

the
function provided by Microsoft does not work!!!!! The code below throws
up
the following error message when I try to run it: Compile error:
User-defined type not defined.

Could anyone please help me rectify this problem??

Function Remove_DBCreate()

Dim d As DAO.Database, c As Container, SystemDB As String
SystemDB = "C:\Program Files\Microsoft Office\" & _
"Office\System.mdw" ' Use path for your system.
Set d = DBEngine(0).OpenDatabase(SystemDB)
Set c = d.Containers!Databases
c.UserName = "Users"
c.Permissions = c.Permissions And Not dbSecDBCreate

End Function

TIA,

Mark

"Mark" <ma*********@ntlworld.com> wrote in message
news:XC*************@newsfe3-win.ntli.net...
> Hi All,
>
> Firstly, I am aware from reading previous posts that if someone is
> determined enough, they will crack an Access Application. However, this
> problem seems basic but I can't find a workaround.
>
> I have a frontend/backend database at work which contains some
> sensitive information. I have used Access security along with my own
> and
> have disabled the shift key at start-up. I thought this was quite
> secure
> but I have found that someone has hacked into it and given themselves
> administrator privileges within my own security. After a lot of
> investigation, I have found out that they have done this by creating a
> new database under my workgroup and then importing the tables from the
> frontend. They can then open up any table they please and have
> visibility of everything due to no form being set to start-up..
>
> I have changed the way my security works by splitting the user table
> down so that the permissions given to each user is split from their
> passwords which they can change and given them only read permissions.
>
> What I want to be able to do is stop people being able to import/link
> from either the FE or BE unless they are the administrator. I have
> spent
> hours looking through the help files but can't see any reference to
> this.
>
> I am using Access 2002 SP2 on a XP platform.
>
> TIA
>
>



Nov 13 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"Mark" <ma*********@ntlworld.com> wrote:
I have had problems with inquisitive souls looking
at data they shouldn't be. I though disabling the ability to create new
databases using my workgroup would stop this but it doesn't. All they
have to do now is create a new database using the default wrkgroup,
close it and then open it again whilst joined to my workgroup and they
can import again. Can someone please help me stop these people
importing from the FE or BE?


Hi Mark,

If a casual user can create a new database using your own customised mdw
file and no hacking tools then the user-level security hasn't been
implemented correctly.

Have you implemented your security as per the MS KB item
<http://support.microsoft.com/default...access%2fconte
nt%2fsecfaq.asp> ?

Have you assigned a password to your Admin account and denied the 'users'
group access to the 'database' object?

Regards,
Keith.
www.keithwilby.org.uk
Nov 13 '05 #2

P: n/a
Hi Keith,
Neither of the groups (Admin/Users) have access to use anything from the
frontend or backend. I have created 2 user accounts, one for myself with
administrator privileges and a general user account with limited access.I
have given the general user account read permissions on all the tables they
need and then controlled what they can and can't do with my own security.
None of the objects in the database can be imported, only the tables because
by default, as soon as you give someone permission to read a table, they
have by default, permission to read the design. Both user accounts have a
password.

I didn't set all the permissions using the wizard but I have spent hours
going through all the permissions on all objects within the database and
general users only have what they need. With all this in place, a general
user can create a new DB using the default MDW. They can then open Access,
join my workgroup and then open their newly created DB and import all tables
they have read permission on. No-one can do this unless they are a member of
my workgroup!!!!!

Am I missing something?

Mark
"Keith Wilby" <ke*********@AwayWithYerCrap.com> wrote in message
news:Xn************************@10.15.188.42...
"Mark" <ma*********@ntlworld.com> wrote:
I have had problems with inquisitive souls looking
at data they shouldn't be. I though disabling the ability to create new
databases using my workgroup would stop this but it doesn't. All they
have to do now is create a new database using the default wrkgroup,
close it and then open it again whilst joined to my workgroup and they
can import again. Can someone please help me stop these people
importing from the FE or BE?


Hi Mark,

If a casual user can create a new database using your own customised mdw
file and no hacking tools then the user-level security hasn't been
implemented correctly.

Have you implemented your security as per the MS KB item
<http://support.microsoft.com/default...access%2fconte
nt%2fsecfaq.asp> ?

Have you assigned a password to your Admin account and denied the 'users'
group access to the 'database' object?

Regards,
Keith.
www.keithwilby.org.uk

Nov 13 '05 #3

P: n/a
"Mark" <ma*********@ntlworld.com> wrote:
I
have given the general user account read permissions on all the tables


Hi Mark,

Don't do this. Instead, use queries with the 'Run permission' property set
to 'Owner's'. This will deny the account's users access to the tables but
they can still retrieve the data via the queries.

Regards,
Keith.
Nov 13 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.