By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,480 Members | 771 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,480 IT Pros & Developers. It's quick & easy.

DB Passwords and Windows Scheduler

P: n/a
I am having trouble using Windows Scheduler with an A2K database that has a
password. The password is a db password, not a user-level security password.
I have a routine I am looking for Scheduler to run, and, when the password
is removed from the database, everything works fine. In that case, the
command line I am having Scheduler use is:

"C:\Program Files\Microsoft Office 2000\Office\MSACCESS.EXE"
"C:\Mypath\MyDB.mdb" /x MacroThatRunsTheRoutine

However, when the db password is in place, I am not able to run the code.
The command line I use then is:

"C:\Program Files\Microsoft Office 2000\Office\MSACCESS.EXE"
"C:\Mypath\Myfile.mdb" /x MacroThatRunsRoutine /pwd DBPassword

When the database password is in place, I am prompted by Scheduler for my
Windows login password. I entered the login password when I created the
scheduled event, so it shouldn't be prompting me. Furthermore, when it does
prompt me, entering my Windows login password doesn't work, nor does
entering the db password.

This appears to be some sort of glitch with Windows Scheduler and MS Access
passwords. Anyone have any ideas?

Thanks!

Neil
Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Re. the previous message I wrote, I just realized that the problem is not
with Windows Scheduler, but with the command-line argument I am using. I am
using:

/pwd DBPassword

in my command line. However, Access is seeing that as a user-level security
password, which it isn't, and, thus, is prompting me for a corrected
user-level security password.

I searched the on-line help for a command-line argument that allows you to
specify a database password, rather than a user-level security password, but
I didn't see any. Anyone know of a way?

Thanks,

Neil
Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.