By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,139 Members | 1,228 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,139 IT Pros & Developers. It's quick & easy.

Asking for database password

P: n/a
Hi all,
This is probably really simple but the answer has eluded me so far. I have a frontend application which when closed on PC's at work, just closes. However, when I close it (an exact copy) on my home PC, the forms & database window close but then prompt for the database password. I can enter the password or click on cancel and then access will shut down. Is there a setting or option I am missing on my home PC? I do not have the same problem with the backend.

Both machines are running XP pro and access 2000.
TIA,

Mark
Nov 13 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hi, Mark.

Your home computer's "Compact on Close" setting is checked, while the
computers at work aren't checked. To match the others, open this database
on your home computer. Open your Tools menu and select Options. Select the
"General" tab in the Options dialog window. A little further than half-way
down on the left side is a check box for "Compact on Close." If you uncheck
this box, then the next time you close the database, it won't compact and
ask you for the password when the compaction is done.

HTH.

Gunny

See http://www.QBuilt.com for all your database needs.
See http://www.Access.QBuilt.com for Microsoft Access tips.
"Mark R" <ma*********@ntlworld.com> wrote in message
news:tQ***************@newsfe1-gui.ntli.net...
Hi all,
This is probably really simple but the answer has eluded me so far. I
have a frontend application which when closed on PC's at work, just closes.
However, when I close it (an exact copy) on my home PC, the forms & database
window close but then prompt for the database password. I can enter the
password or click on cancel and then access will shut down. Is there a
setting or option I am missing on my home PC? I do not have the same problem
with the backend.

Both machines are running XP pro and access 2000.
TIA,

Mark
Nov 13 '05 #2

P: n/a
I believe Gunny is correct. If I remember correctly, Access 2000 needed the
password to reopen the database after a compact. Access 2002 and 2003 don't
do this.

--
Wayne Morgan
MS Access MVP
"'69 Camaro" <Bl********************@Spameater.org> wrote in message
news:qI****************@nwrddc02.gnilink.net...
Hi, Mark.

Your home computer's "Compact on Close" setting is checked, while the
computers at work aren't checked. To match the others, open this database
on your home computer. Open your Tools menu and select Options. Select
the
"General" tab in the Options dialog window. A little further than
half-way
down on the left side is a check box for "Compact on Close." If you
uncheck
this box, then the next time you close the database, it won't compact and
ask you for the password when the compaction is done.

HTH.

Gunny

Nov 13 '05 #3

P: n/a
Many Thanks
"Wayne Morgan" <co***************************@hotmail.com> wrote in message news:8N***************@newssvr22.news.prodigy.com. ..
I believe Gunny is correct. If I remember correctly, Access 2000 needed the
password to reopen the database after a compact. Access 2002 and 2003 don't
do this.

--
Wayne Morgan
MS Access MVP
"'69 Camaro" <Bl********************@Spameater.org> wrote in message
news:qI****************@nwrddc02.gnilink.net...
Hi, Mark.

Your home computer's "Compact on Close" setting is checked, while the
computers at work aren't checked. To match the others, open this database
on your home computer. Open your Tools menu and select Options. Select
the
"General" tab in the Options dialog window. A little further than
half-way
down on the left side is a check box for "Compact on Close." If you
uncheck
this box, then the next time you close the database, it won't compact and
ask you for the password when the compaction is done.

HTH.

Gunny

Nov 13 '05 #4

P: n/a
Glad it helped!

Gunny

See http://www.QBuilt.com for all your database needs.
See http://www.Access.QBuilt.com for Microsoft Access tips.
"Mark R" <ma*********@ntlworld.com> wrote in message
news:lP************@newsfe4-gui.ntli.net...
Many Thanks
"Wayne Morgan" <co***************************@hotmail.com> wrote in
message news:8N***************@newssvr22.news.prodigy.com. ..
I believe Gunny is correct. If I remember correctly, Access 2000 needed
the
password to reopen the database after a compact. Access 2002 and 2003
don't
do this.

--
Wayne Morgan
MS Access MVP
"'69 Camaro" <Bl********************@Spameater.org> wrote in message
news:qI****************@nwrddc02.gnilink.net...
Hi, Mark.

Your home computer's "Compact on Close" setting is checked, while the
computers at work aren't checked. To match the others, open this database on your home computer. Open your Tools menu and select Options. Select
the
"General" tab in the Options dialog window. A little further than
half-way
down on the left side is a check box for "Compact on Close." If you
uncheck
this box, then the next time you close the database, it won't compact and ask you for the password when the compaction is done.

HTH.

Gunny


Nov 13 '05 #5

P: n/a
Ditch the HTML. Send plain text only.
"Mark R" <ma*********@ntlworld.com> wrote in message news:lP************@newsfe4-gui.ntli.net...
Many Thanks
"Wayne Morgan" <co***************************@hotmail.com> wrote in message news:8N***************@newssvr22.news.prodigy.com. ..
I believe Gunny is correct. If I remember correctly, Access 2000 needed the
password to reopen the database after a compact. Access 2002 and 2003 don't
do this.

--
Wayne Morgan
MS Access MVP
"'69 Camaro" <Bl********************@Spameater.org> wrote in message
news:qI****************@nwrddc02.gnilink.net...
Hi, Mark.

Your home computer's "Compact on Close" setting is checked, while the
computers at work aren't checked. To match the others, open this database
on your home computer. Open your Tools menu and select Options. Select
the
"General" tab in the Options dialog window. A little further than
half-way
down on the left side is a check box for "Compact on Close." If you
uncheck
this box, then the next time you close the database, it won't compact and
ask you for the password when the compaction is done.

HTH.

Gunny

Nov 13 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.