By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,107 Members | 1,323 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,107 IT Pros & Developers. It's quick & easy.

createdatabase creates wrong version of access db

P: n/a
I am using the following code in an access2002 db to create another
access db:

Set dbsNew = wspDefault.CreateDatabase("c:\propfnldata.mdb",
dbLangGeneral, dbVersion30)

which should create an access95 db, but it is creating it in
access2000. Does anyone know why? I need it to be in access95 (or 97)
format.
Nov 13 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Jeff, just tried your code, and it created a file that opened fine in Access
97.

If yours does not work, do you have at least SP2 for Office XP, and SP8 for
JET 4?

The actual code I tested was:

Function MakeDb()
Dim wspDefault As DAO.Workspace
Dim dbsNew As DAO.Database

Set wspDefault = DBEngine(0)
Set dbsNew = wspDefault.CreateDatabase("c:\propfnldata.mdb",
dbLangGeneral, dbVersion30)

Set dbsNew = Nothing
Set wspDefault = Nothing
End Function
--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Jeff" <jm*******@ruralins.com> wrote in message
news:95**************************@posting.google.c om...
I am using the following code in an access2002 db to create another
access db:

Set dbsNew = wspDefault.CreateDatabase("c:\propfnldata.mdb",
dbLangGeneral, dbVersion30)

which should create an access95 db, but it is creating it in
access2000. Does anyone know why? I need it to be in access95 (or 97)
format.

Nov 13 '05 #2

P: n/a
"Allen Browne" <Al*********@SeeSig.Invalid> wrote in message news:<41***********************@per-qv1-newsreader-01.iinet.net.au>...
Jeff, just tried your code, and it created a file that opened fine in Access
97.

If yours does not work, do you have at least SP2 for Office XP, and SP8 for
JET 4?

The actual code I tested was:

Function MakeDb()
Dim wspDefault As DAO.Workspace
Dim dbsNew As DAO.Database

Set wspDefault = DBEngine(0)
Set dbsNew = wspDefault.CreateDatabase("c:\propfnldata.mdb",
dbLangGeneral, dbVersion30)

Set dbsNew = Nothing
Set wspDefault = Nothing
End Function
--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Jeff" <jm*******@ruralins.com> wrote in message
news:95**************************@posting.google.c om...
I am using the following code in an access2002 db to create another
access db:

Set dbsNew = wspDefault.CreateDatabase("c:\propfnldata.mdb",
dbLangGeneral, dbVersion30)

which should create an access95 db, but it is creating it in
access2000. Does anyone know why? I need it to be in access95 (or 97)
format.


Allen, thanks for responding. Yes, i have both SP2 and SP8. My code
is the same as yours. The situation is this: I have to support an
access application which is distributed to various computers around
the state. They were all on access 97. Basically, what they would do
is use the application to send information to each other via e-mail.
In the e-mail is the access db created from their application, which
they could open, no problem. This process cannot be changed. However,
some of these field pc's now have access2002 on them, and when they
create the db to send, it is creating it in access2000 format, which
the access97 apps cannot handle. The help for the createdatabase
command in access 2002 says that the dbVersion30 parameter should
create the database in access95 format, but it obviously is not. What
is odd is that we have an almost identical application (access 2002
also) at the home office which does the same thing, and it does create
the db in access95 format. I cannot figure this out. Any further
thoughts would be appreciated.
Nov 13 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.