By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,241 Members | 760 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,241 IT Pros & Developers. It's quick & easy.

How come I sometimes get this?? "Run-time error 3211: can't lock table. "

P: n/a
My app is giving me this error.

Run-time error 3211:
The database engine could not lock table 'Sorted_Template' because it is
already in use by another person or process.

When I run the app the first time through, it runs fine. I get this when I
run a make-table query that tries to write out the table called
"Sorted_Template". I tried using a TableDefs.Delete command thinking that
make using the docmd.openquery was causing the problem. But it cannot
delete the table either - I get the same error msg.

The table at this point should not be in use by another process and I am the
only user. So what gives? I am using this in an automation project but at
this point I am not calling any other MS Office apps. But I do establish a
recordset variable early in the code. It is closed and the var set to
nothing when the sub ends so I do not see how that is the problem.

Any ideas?

Thanks
Nov 13 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.