By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
460,035 Members | 937 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 460,035 IT Pros & Developers. It's quick & easy.

"Opened Exclusively" message on same machine with 2 of 3 Windows users

P: n/a
I have a database split into front-end, back-end, on a machine running
Windows XP professional (no network, just a single machine). I just
upgraded the database from Access 97 to Access 2000. The machine has 3
users logging into the machine, one of which is the Administrator.

In addition, I have activated the Access security, with the same 3 users (I
won't get into why now - it's a long story).

When I am logged into Windows XP with one of the users (User2), I can get
into the database with no problem using any Access User ID. However, when I
am logged into the machine as the other 2 users, I get the "opened
exclusively by another user" message, no matter which Access User ID I use.
At first I thought this was a Windows XP permission problem, but one of the
Windows IDs that gets the "opened exclusively" message is the Administrator!

So to recap:

Windows User Access User Error Message?

Administrator Admin Yes
Administrator User2 Yes
Administrator User3 Yes
User2 Admin No
User2 User2 No
User2 User3 No
User3 Admin Yes
User3 Admin Yes
User3 Admin Yes

Looking back on things, I think that I upgraded the database while I was
logged in as User2, so it looks like this problem has something to do with
who "owns" the database as far as Windows is concerned. One last note: the
problem seems to be the back-end database, not the front-end.

Does anyone have any ideas? I can't find any KB article that seems to fit
this.

Shannon
Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Check for delete permissions. It looks like you opened
Exclusive (as you need to do to make design changes), and
you were unable to delete the LDB file when you closed the
mdb.

(david)

"Shannon Rotz" <sr***@shaw.ca> wrote in message
news:GMmGc.30713$WB5.9307@pd7tw2no...
I have a database split into front-end, back-end, on a machine running
Windows XP professional (no network, just a single machine). I just
upgraded the database from Access 97 to Access 2000. The machine has 3
users logging into the machine, one of which is the Administrator.

In addition, I have activated the Access security, with the same 3 users (I won't get into why now - it's a long story).

When I am logged into Windows XP with one of the users (User2), I can get
into the database with no problem using any Access User ID. However, when I am logged into the machine as the other 2 users, I get the "opened
exclusively by another user" message, no matter which Access User ID I use. At first I thought this was a Windows XP permission problem, but one of the Windows IDs that gets the "opened exclusively" message is the Administrator!
So to recap:

Windows User Access User Error Message?

Administrator Admin Yes
Administrator User2 Yes
Administrator User3 Yes
User2 Admin No
User2 User2 No
User2 User3 No
User3 Admin Yes
User3 Admin Yes
User3 Admin Yes

Looking back on things, I think that I upgraded the database while I was
logged in as User2, so it looks like this problem has something to do with
who "owns" the database as far as Windows is concerned. One last note: the problem seems to be the back-end database, not the front-end.

Does anyone have any ideas? I can't find any KB article that seems to fit
this.

Shannon

Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.