By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,491 Members | 1,868 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,491 IT Pros & Developers. It's quick & easy.

Deleting Workgroups

P: n/a
I have recieved a database on which security was supposed to be set
up. What was actually set up was a workgroup.

Now all databases are using this workgroup on start up and, despite
the fact that I am supposed to be the database adminstrator, I cannot
amend some of the more vital forms.

I have not worked with workgroups before because I have developed my
own internal passwording system which I fid very secure and easy to
administer. The database provider suggested that I copy the Admin
user back into the Admins group, which I did, but rather stupidly I
didn't switch all permissions back on to the Admin user.

I can't believe that MS would provide a system that would let you
delete all permissions from all users, but I cannot find a way of
getting the permissions back on... what I really want to do is restore
the standard workgroup to this database, and to all of the other
databases that have been affected by it, and attach all users back to
the standard workgroup.

Anyone help??!

Katie
Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Hello, Katie!

Access security can be frustrating to learn, but it does provide a higher
degree of security than most home-grown systems. It also provides a
standard model so that all programmers who are familiar with Access security
understand how each others' systems work.

Access security can be invoked in one of two ways.
If you join a workgroup, its security features apply to all MDB files you
open.
It sounds as if this is what you have done.

Alternatively, you can invoke security from a command line, something like
this:
"C:\Program Files\Microsoft Office\Office\MSAccess.EXE"
"C:\MyFiles\MyDB.MDB" /wrkgrp "C:\MyFiles\MyWorkGroup.MDW"
That's a lot to type in each time, so I usually use a desktop shortcut, with
this as the target line.
This applies the MyWorkGroup.MDW only to the file you are opening.

I'd suggest that you rejoin your original System.MDW file, so that your
pre-existing databases will now function as before. Invoking the WorkGroup
Administrator changed between Access 2000 and Access 2002, so without
knowing which version you're using, I can't give you explicit instructions.
You may find doing a search in Windows Explorer the easiest way to locate
that System.MDW file - I think Microsoft tends to put it in a hidden folder
somewhere under Documents and Settings.

Once you've done this, go ahead and make a shortcut based on the command
line I gave you above.
That should get you into your new program with the security features it
uses.

Do post back if you need more assistance.
- Turtle

"Katie" <ka********@northernrock.co.uk> wrote in message
news:43*************************@posting.google.co m...
I have recieved a database on which security was supposed to be set
up. What was actually set up was a workgroup.

Now all databases are using this workgroup on start up and, despite
the fact that I am supposed to be the database adminstrator, I cannot
amend some of the more vital forms.

I have not worked with workgroups before because I have developed my
own internal passwording system which I fid very secure and easy to
administer. The database provider suggested that I copy the Admin
user back into the Admins group, which I did, but rather stupidly I
didn't switch all permissions back on to the Admin user.

I can't believe that MS would provide a system that would let you
delete all permissions from all users, but I cannot find a way of
getting the permissions back on... what I really want to do is restore
the standard workgroup to this database, and to all of the other
databases that have been affected by it, and attach all users back to
the standard workgroup.

Anyone help??!

Katie

Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.