By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,688 Members | 1,845 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,688 IT Pros & Developers. It's quick & easy.

How do I define my db if I'm working on Access 2000 and also linking to SQL Server Enterprise Manager

P: n/a
I'm working on a db on Access 2000. I'm also linking that db to some
tables on SQL Server Enterprise Manager. My code is stop running at
the statement, set db=CurrentDb()?
Is that the reason I got run-time error 13' Type mismatch?
Please help!
Thank you very much.
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Database is a DAO object. By default, Access 2000 uses ADO.

With any code module open, select Tools | References from the menu bar,
scroll through the list of available references until you find the one for
Microsoft DAO 3.6 Object Library, and select it. If you're not going to be
using ADO, uncheck the reference to Microsoft ActiveX Data Objects 2.1
Library

If you have both references, you'll find that you'll need to "disambiguate"
certain declarations, because objects with the same names exist in the 2
models. For example, to ensure that you get a DAO recordset, you'll need to
use Dim rsCurr as DAO.Recordset (to guarantee an ADO recordset, you'd use
Dim rsCurr As ADODB.Recordset)

The list of objects with the same names in the 2 models is Connection,
Error, Errors, Field, Fields, Parameter, Parameters, Property, Properties
and Recordset
--
Doug Steele, Microsoft Access MVP
http://I.Am/DougSteele
(no e-mails, please!)
"lphuong" <lp*****@neh.gov> wrote in message
news:b6**************************@posting.google.c om...
I'm working on a db on Access 2000. I'm also linking that db to some
tables on SQL Server Enterprise Manager. My code is stop running at
the statement, set db=CurrentDb()?
Is that the reason I got run-time error '13' Type mismatch?
Please help!
Thank you very much.

Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.