By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,397 Members | 1,467 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,397 IT Pros & Developers. It's quick & easy.

Runaway Scrolling In Form

P: n/a
Putting focus in a form element like a dropdown box and using the mouse
wheel - even one click forward or backward with it - cycles through
every record, in that direction, until first or last record is reached.

MSKB has a VB workaround for making Access unresponsive to the mouse
wheel, but I don't need to prevent that -- just the *runaway* cycling.
Any ideas? I've not seen this behavior in any other applications.

Logitech USB optical mouse; Mouseware 9.70; Win98SE.

--
Thomas Winston Ping
Nov 12 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Thomas,
I believe I've had this problem, and it turned out to be a bug in the
mouse driver. Does the same kind of behavior occur with Word? Are
there any events that run OnCurrent that might advance the record?
Finally, what happens when you set the Cycle property to Current Record?

Cheers,

Eric

Thomas W Ping wrote:
Putting focus in a form element like a dropdown box and using the mouse
wheel - even one click forward or backward with it - cycles through
every record, in that direction, until first or last record is reached.

MSKB has a VB workaround for making Access unresponsive to the mouse
wheel, but I don't need to prevent that -- just the *runaway* cycling.
Any ideas? I've not seen this behavior in any other applications.

Logitech USB optical mouse; Mouseware 9.70; Win98SE.

Nov 12 '05 #2

P: n/a
Eric Ellsworth wrote:
I believe I've had this problem, and it turned out to be a bug in the
mouse driver. Does the same kind of behavior occur with Word? Are
I've never had a form in Word with a field represented by a dropdown.
there any events that run OnCurrent that might advance the record?
Nope.
Finally, what happens when you set the Cycle property to Current Record?
<clickety-click>

The same thing.
Thomas W Ping wrote:
Putting focus in a form element like a dropdown box and using the mouse
wheel - even one click forward or backward with it - cycles through
every record, in that direction, until first or last record is reached. MSKB has a VB workaround for making Access unresponsive to the mouse
wheel, but I don't need to prevent that -- just the *runaway* cycling.
Any ideas? I've not seen this behavior in any other applications. Logitech USB optical mouse; Mouseware 9.70; Win98SE.


--
Blinky Linux Registered User 297263
AOL Diary http://snipurl.com/aoldiary
Nigerian Scam From Space http://snipurl.com/iss419
New Windows - Don't Wait For Longhorn! http://snipurl.com/newwin
Nov 13 '05 #3

P: n/a
If you are using Access 97 then this a known bug that I believe was
fixed in the last Service Release for A97.

--

HTH
Stephen Lebans
http://www.lebans.com
Access Code, Tips and Tricks
Please respond only to the newsgroups so everyone can benefit.
"Blinky the Shark" <no*****@box.invalid> wrote in message
news:sl********************@thurston.blinkynet.net ...
Eric Ellsworth wrote:
I believe I've had this problem, and it turned out to be a bug in the
mouse driver. Does the same kind of behavior occur with Word? Are
I've never had a form in Word with a field represented by a dropdown.
there any events that run OnCurrent that might advance the record?


Nope.
Finally, what happens when you set the Cycle property to Current

Record?
<clickety-click>

The same thing.
Thomas W Ping wrote:
Putting focus in a form element like a dropdown box and using the mouse wheel - even one click forward or backward with it - cycles through
every record, in that direction, until first or last record is reached.
MSKB has a VB workaround for making Access unresponsive to the
mouse wheel, but I don't need to prevent that -- just the *runaway* cycling. Any ideas? I've not seen this behavior in any other applications.

Logitech USB optical mouse; Mouseware 9.70; Win98SE.


--
Blinky Linux Registered User 297263
AOL Diary http://snipurl.com/aoldiary
Nigerian Scam From Space http://snipurl.com/iss419
New Windows - Don't Wait For Longhorn! http://snipurl.com/newwin


Nov 13 '05 #4

P: n/a
Stephen Lebans wrote:
If you are using Access 97 then this a known bug that I believe was
fixed in the last Service Release for A97.


I couldn't find any solutions via Google or Google Groups on (I checked
before posting), but I'll re-research that. Thanks.

--
Thomas Winston Ping
Nov 13 '05 #5

P: n/a
You really should learn how to search the MS KB. It is an invaluable
tool!
:-)

http://support.microsoft.com/default...2008&Product=a
cc97
ACC97: Erratic Intellimouse Scrolling in Forms and Tables
View products that this article applies to.
This article was previously published under Q192008
Novice: Requires knowledge of the user interface on single-user
computers.
SYMPTOMS
When you use the Microsoft Intellimouse with Microsoft Access 97 on
Windows 98, you may experience one or more of the following symptoms:

In a form that includes a subform in Datasheet view, you can't scroll in
a subform with the Intellimouse wheel.
In a form that includes a subform in Datasheet view, the subform scrolls
to the end of the recordset if you roll the Intellimouse wheel one click
downward.
In a table, the display is moved immediately to the first or last record
in the table if you roll the Intellimouse wheel one click downward or
upward.
In a table, the display is moved a random number of records up or down
if you roll the Intellimouse wheel one click upward or downward.
RESOLUTION
To resolve this problem, obtain Microsoft Office 97 Service Release 2
(SR-2).

For more information about getting this Service Release, see the
following article in the Microsoft Knowledge Base:

151261 OFF97: How to Obtain and Install MS Office 97 SR-2

You can work around this behavior temporarily by disabling the
IntelliMouse wheel. To do so, follow these steps:

Click Start, point to Settings, and then click Control Panel.
In Control Panel, double-click the Mouse icon.
In the Mouse Properties dialog box, click the Wheel tab.
Click the Turn On The Wheel check box to clear it.
Click OK.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. This problem no longer occurs
in Microsoft Access 97 SR-2.
The information in this article applies to:
Microsoft Access 97
--

HTH
Stephen Lebans
http://www.lebans.com
Access Code, Tips and Tricks
Please respond only to the newsgroups so everyone can benefit.
"Thomas W Ping" <me@privacy.net> wrote in message
news:2h************@uni-berlin.de...
Stephen Lebans wrote:
If you are using Access 97 then this a known bug that I believe was
fixed in the last Service Release for A97.
I couldn't find any solutions via Google or Google Groups on (I

checked before posting), but I'll re-research that. Thanks.

--
Thomas Winston Ping


Nov 13 '05 #6

P: n/a
Stephen Lebans wrote:
You really should learn how to search the MS KB. It is an invaluable
tool!
:-)
And you really should read my original post, where I said I found that
MSKB article before asking here, but consider it overkill as a solution
to my issue.
You can work around this behavior temporarily by disabling the
IntelliMouse wheel. To do so, follow these steps:


--
Thomas Winston Ping
Nov 13 '05 #7

P: n/a
Thomas I think you are confusing two different issues. THe KB article I
pointed you to requires you to install the Microsoft Office 97 Service
Release 2 (SR-2). I'm not talking about any of the solutions out there
that disable the MouseWheel, just the fact that there is a bug in the
original release of A97 that is fixed in SR2.
http://support.microsoft.com/default...2008&Product=a
cc97

I am very familiar with the MS KB VB solution to disable the MouseWheel.
You can find the source and a compiled ActiveX DLL on my site that fixes
a bug with the MS KB version. Better yet, I wrote a standard C++ based
Windows DLL that resolves the issue in a much cleaner fashion.

--
HTH
Stephen Lebans
http://www.lebans.com
Access Code, Tips and Tricks
Please respond only to the newsgroups so everyone can benefit.
"Thomas W Ping" <me@privacy.net> wrote in message
news:2h************@uni-berlin.de...
Stephen Lebans wrote:
You really should learn how to search the MS KB. It is an invaluable
tool!
:-)
And you really should read my original post, where I said I found that
MSKB article before asking here, but consider it overkill as a

solution to my issue.
You can work around this behavior temporarily by disabling the
IntelliMouse wheel. To do so, follow these steps:


--
Thomas Winston Ping


Nov 13 '05 #8

P: n/a
Stephen Lebans wrote:
Thomas I think you are confusing two different issues. THe KB article
I pointed you to requires you to install the Microsoft Office 97
Service Release 2 (SR-2). I'm not talking about any of the solutions
out there that disable the MouseWheel, just the fact that there is a
bug in the original release of A97 that is fixed in SR2. http://support.microsoft.com/default...2008&Product=a
cc97
Your post (the I was responding to) quotes the above MSKB article, which
does recommend the SP fix...but it also goes on to say, "You can work
around this behavior temporarily by disabling the IntelliMouse wheel. To
do so, follow these steps: [and tells the totally clueless (worse than
me! <g>) how to disable the wheel in Control Panel].

My bad -- I picked up on that line ("...work around...disabling
the...wheel...") and did mistake it for the MSKB article I'd found
(before posting my question, here) here:

http://support.microsoft.com/default...79&Product=acc

I didn't look far enough down to see that it was a CP mouse "fix", and not
the VB recommendations that I'd found myself, thus thinking it was the
same article. D'oh.

Sorry about my bad spot-reading of your post on the SP.
I am very familiar with the MS KB VB solution to disable the
MouseWheel. You can find the source and a compiled ActiveX DLL on my
site that fixes a bug with the MS KB version. Better yet, I wrote a
standard C++ based Windows DLL that resolves the issue in a much
cleaner fashion.
I'll check out your site.

Thanks.
-- HTH Stephen Lebans http://www.lebans.com Access Code, Tips and
Tricks Please respond only to the newsgroups so everyone can benefit. "Thomas W Ping" <me@privacy.net> wrote in message
news:2h************@uni-berlin.de...
Stephen Lebans wrote:
> You really should learn how to search the MS KB. It is an
> invaluable tool!
>:-)
And you really should read my original post, where I said I found
that MSKB article before asking here, but consider it overkill as a

solution
to my issue. > You can work around this behavior temporarily by disabling the
> IntelliMouse wheel. To do so, follow these steps:

-- Thomas Winston Ping


--
Thomas Winston Ping
Nov 13 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.