By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,099 Members | 2,144 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,099 IT Pros & Developers. It's quick & easy.

Subreport showing all but one row - still trying for an answer

P: n/a
rr@kristin.school.nz (Wayne) wrote in message news:<7e**************************@posting.google. com>...
I have a subreport in my report and when it contains exactly one row,
it works fine. In every other case, it displays all but the last row.
The subreport grows large enough to show this last row but leaves it
blank.
Can anyone shed some light on this for me?
Wayne


Since posting the original message I have had no replies. I'm a bit
disappointed. It could be:
a) others have had this problem but found no answer.
b) the answer is so trivial that no-one wanted to embarass me with it.
c) I didn't give enough info.
d) Something else.

The only extra info I can think of is that when the subreport
properties CanGrow and CanShrink are set to true, the subreport
appears large enough for exactly the right number of rows in every
case, leaving the final row blank in all cases of more than one row.
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
CDB
Have you checked that the query shows the right rows for that subreport
child value? For example, it may be that the last record entered has not
been completed and therefore not yet written. (Test by pressing Sh-Ent to
force a write, then call the report.)

Do you have any code or calculations within the report and subreport?

Is the Master/Child linking set up correctly (It has been know to be flakey
at times).

Do you have even one pixel of another object impinging on the entire
horizontal space alongside the subreport?

Do you have any other report sections appearing below the subreport, perhaps
with some clear space, and cutting the subreport off?


"Wayne" <rr@kristin.school.nz> wrote in message
news:7e**************************@posting.google.c om...
rr@kristin.school.nz (Wayne) wrote in message

news:<7e**************************@posting.google. com>...
I have a subreport in my report and when it contains exactly one row,
it works fine. In every other case, it displays all but the last row.
The subreport grows large enough to show this last row but leaves it
blank.
Can anyone shed some light on this for me?
Wayne


Since posting the original message I have had no replies. I'm a bit
disappointed. It could be:
a) others have had this problem but found no answer.
b) the answer is so trivial that no-one wanted to embarass me with it.
c) I didn't give enough info.
d) Something else.

The only extra info I can think of is that when the subreport
properties CanGrow and CanShrink are set to true, the subreport
appears large enough for exactly the right number of rows in every
case, leaving the final row blank in all cases of more than one row.

Nov 12 '05 #2

P: n/a
I didn't post this before because my recollection of the situation is
vague. I was using VBA code in a report to change the height of the
detail section dynamically because the user had 70 pages of output and
needed to have blank lines condense. I had to adjust the size of the
detail section in design mode to accomodate the new strategy. After
saving the resulting report I noticed the situation that you describe.
I just increased the size of the detail section in design mode and the
missing information returned. I don't know if this helps you with
your situation or not.

James A. Fortune

Our business is to establish peace and order on a satisfactory basis,
start the new government, and then leave the Island; the Cuban
Government taking the reins into its own hands; tho of course it might
be advisable for some little time that some of our troops should stay
in the Islands to steady things.

--- Theodore Roosevelt 1907
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.