By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,483 Members | 1,939 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,483 IT Pros & Developers. It's quick & easy.

REQ HELP: Date Format Mysteriously Changed Globally to Four Digit Year

P: n/a
Hi,

I don't know what happened, but all the MS Access dates in all tables,
queries, forms, and reports in all databases suddenly show on my
computer with the year as 4 digits (including network databases I
access on my computer). It used to always be 2 digits.

I have been changing the format of dates in all my databases tables,
queries, forms, and reports to mm/dd/yy and that was working for a
while. But today, the reports I made this change would no longer open
in design more or report mode.

Even when it works, this method is tedious and time-consuming.

If someone knows how to fix this, will they please let me know?

MHenry

Nov 12 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
"MHenry" <MH****@NoSpam.net> wrote in message
news:sp********************************@4ax.com...
Hi,

I don't know what happened, but all the MS Access dates in all tables,
queries, forms, and reports in all databases suddenly show on my
computer with the year as 4 digits (including network databases I
access on my computer). It used to always be 2 digits.

I have been changing the format of dates in all my databases tables,
queries, forms, and reports to mm/dd/yy and that was working for a
while. But today, the reports I made this change would no longer open
in design more or report mode.

Even when it works, this method is tedious and time-consuming.

If someone knows how to fix this, will they please let me know?


If you use a *named* format (short, medium, long, currency, etc.), then
Access uses the definitions of these as set in the Windows Regional
Settings of Control Panel. My guess is that your regional setting was
recently changed.

If you use a format property string (mm/dd/yy, yyyy-m-d, #0.00, etc.) then
they should always be honored regardless of regional settings.
--
I don't check the Email account attached
to this message. Send instead to...
RBrandt at Hunter dot com


Nov 12 '05 #2

P: n/a
MHenry <MH****@NoSpam.net> wrote in news:sp3090png0ap1lqv7ot0grr0ek1shlhn9h@
4ax.com:
I don't know what happened, but all the MS Access dates in all tables,
queries, forms, and reports in all databases suddenly show on my
computer with the year as 4 digits (including network databases I
access on my computer). It used to always be 2 digits.
Give thanks!
I have been changing the format of dates in all my databases tables,
queries, forms, and reports to mm/dd/yy and that was working for a
while.
That's incredible.
But today, the reports I made this change would no longer open
in design more or report mode.


Access is a just program.

--
Lyle
(for e-mail refer to http://ffdba.com/contacts.htm)
Nov 12 '05 #3

P: n/a
Thank you, Rick.

I changed my short date to the way I wanted it in my Regional
Settings. All is well in Smallville again.
I have no idea how it got changed, but I guess it must have.
Maybe some program I recently installed did it?
Actually, I have updated a couple of programs. bit installed no new
programs.
Maybe it could have been a Windows Update?
If so, I guess some other people would have the same problem.

MHenry
On Wed, 28 Apr 2004 15:44:24 -0500, "Rick Brandt"
<ri*********@hotmail.com> wrote:
"MHenry" <MH****@NoSpam.net> wrote in message
news:sp********************************@4ax.com.. .
Hi,

I don't know what happened, but all the MS Access dates in all tables,
queries, forms, and reports in all databases suddenly show on my
computer with the year as 4 digits (including network databases I
access on my computer). It used to always be 2 digits.

I have been changing the format of dates in all my databases tables,
queries, forms, and reports to mm/dd/yy and that was working for a
while. But today, the reports I made this change would no longer open
in design more or report mode.

Even when it works, this method is tedious and time-consuming.

If someone knows how to fix this, will they please let me know?


If you use a *named* format (short, medium, long, currency, etc.), then
Access uses the definitions of these as set in the Windows Regional
Settings of Control Panel. My guess is that your regional setting was
recently changed.

If you use a format property string (mm/dd/yy, yyyy-m-d, #0.00, etc.) then
they should always be honored regardless of regional settings.

Nov 12 '05 #4

P: n/a
"MHenry" <MH****@NoSpam.net> wrote in message
news:ln********************************@4ax.com...
Thank you, Rick.

I changed my short date to the way I wanted it in my Regional
Settings. All is well in Smallville again.
I have no idea how it got changed, but I guess it must have.
Maybe some program I recently installed did it?
Actually, I have updated a couple of programs. bit installed no new
programs.
Maybe it could have been a Windows Update?
If so, I guess some other people would have the same problem.


That's why if you really care you should avoid the named constants. If your
app is used by others the format will follow whatever their regional
settings are. Why would you want a 2 digit year anyway? Did you forget
about that mess a while back already :-)

Nov 12 '05 #5

P: n/a
On Wed, 28 Apr 2004 21:24:21 -0500, "Rick Brandt"
<ri*********@hotmail.com> wrote:
"MHenry" <MH****@NoSpam.net> wrote in message
news:ln********************************@4ax.com.. .
Thank you, Rick.

I changed my short date to the way I wanted it in my Regional
Settings. All is well in Smallville again.
I have no idea how it got changed, but I guess it must have.
Maybe some program I recently installed did it?
Actually, I have updated a couple of programs. bit installed no new
programs.
Maybe it could have been a Windows Update?
If so, I guess some other people would have the same problem.
That's why if you really care you should avoid the named constants. If your
app is used by others the format will follow whatever their regional
settings are. Why would you want a 2 digit year anyway? Did you forget
about that mess a while back already :-)


Hi, Rick,

I gave a passing thought to the Y2K hoopla as I muddled through this,
but my reasons for wanting 2 year display are for space and
consistency. I have many columns in my tables and subforms and I like
to see as many of the columns as possible without scrolling. I had to
increase my column widths to see the full date when it switched to
four digits. The chance for confusion in dates is slight as my
databases are rather small, limited to my clients and their financial
activities.

Nov 12 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.