By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,509 Members | 2,234 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,509 IT Pros & Developers. It's quick & easy.

? User level security glitch

P: n/a
Using Access 2000 and 2002

Have set up user-level security with a new .mdw file (secured.mdw).

I open my database with a short cut whose target includes a command line option
for the workgroup .mdw file. This seems to work for the user-level security.

However, if I go directly (through Explorer) to the Access .mdb file of my
program (Program.mdb) and double click to start this .mdb file, the program
opens without any security!!

This does not seem like very good security to me. Is there any way to associate
my .mdb program with that .mdw file no matter how I choose to open my program?

Thank you for the help in advance.
Nov 12 '05 #1
Share this Question
Share on Google+
13 Replies


P: n/a
MFS 43 wrote:
Using Access 2000 and 2002

Have set up user-level security with a new .mdw file (secured.mdw).

I open my database with a short cut whose target includes a command line option
for the workgroup .mdw file. This seems to work for the user-level security.

However, if I go directly (through Explorer) to the Access .mdb file of my
program (Program.mdb) and double click to start this .mdb file, the program
opens without any security!!

This does not seem like very good security to me. Is there any way to associate
my .mdb program with that .mdw file no matter how I choose to open my program?

Thank you for the help in advance.


First thing about security is not let "admin" have any rights as this is
the default login. You can use the workgroup administrator to set the
default mdw to your secured one but this will only work for your machine.

Some light reading for you
http://support.microsoft.com/default...ent/secfaq.asp
or http://tinyurl.com/4tye if the above wraps.
--
But why is the Rum gone?
Nov 12 '05 #2

P: n/a

"MFS 43" <mf***@aol.com> wrote in message
news:20***************************@mb-m20.aol.com...
Using Access 2000 and 2002

Have set up user-level security with a new .mdw file (secured.mdw).

I open my database with a short cut whose target includes a command line option for the workgroup .mdw file. This seems to work for the user-level security.

However, if I go directly (through Explorer) to the Access .mdb file of my
program (Program.mdb) and double click to start this .mdb file, the program
opens without any security!!

This does not seem like very good security to me. Is there any way to associate my .mdb program with that .mdw file no matter how I choose to open my program?


Yeah, start over and do it correctly :-). This is a classic sign that you
didn't.
--
I don't check the Email account attached
to this message. Send instead to...
RBrandt at Hunter dot com
Nov 12 '05 #3

P: n/a
I have done that. I have taken all the rights away from Admin in my secured
..mdw file and succesfully created an .mdw file.

As you mentioned I can change my default .mdw for my machine. I believe this is
done by changes in the registry.

But whether I change the registry on my machine or use an icon whose target
includes my .mdw file there is a simple way to "break" the security.

If I change the registry, all that needs to be done is change the registry back
to system.mdw.

If I start with an icon specifying an .mdw file, you can get around this by
starting the program without the icon i.e. by clicking directly on the program
file name (.mdb) in Explorer.

There must be a way to prevent this. I can't believe Microsoft has created a
security system that is so easy to get through.

Thanks for your help.
Nov 12 '05 #4

P: n/a
If this is a "classic sign", I will start over.

Thanks for the help.
Nov 12 '05 #5

P: n/a
MFS 43 wrote:
I have done that. I have taken all the rights away from Admin in my secured
.mdw file and succesfully created an .mdw file.

As you mentioned I can change my default .mdw for my machine. I believe this is
done by changes in the registry.
Well, easier than that, Tools->Security->Workgroup Administrator
But whether I change the registry on my machine or use an icon whose target
includes my .mdw file there is a simple way to "break" the security.

If I change the registry, all that needs to be done is change the registry back
to system.mdw.

If I start with an icon specifying an .mdw file, you can get around this by
starting the program without the icon i.e. by clicking directly on the program
file name (.mdb) in Explorer.

There must be a way to prevent this. I can't believe Microsoft has created a
security system that is so easy to get through.


If you had removed Admin's rights then double clicking on the MDB file
would yield no access into the database. Unless I'm mistaken as I
haven't used Access' security in a long time as I tend to use MDEs for
front end and SQL Server for the back-end.

--
But why is the Rum gone?
Nov 12 '05 #6

P: n/a
You're correct.

I have redone the Security Wizard and the database seems secure now but I can't
open the program by clicking on the MDB file OR by opening access and then
choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the
MDW file. This is OK but then I don't know how I could get in if I wanted to
open the file exclusively.
Nov 12 '05 #7

P: n/a
I have redone the Security Wizard and the database seems VERY secure now but I
can't open the program by clicking on the MDB file OR by opening access and
then choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the
MDW file. This is OK but then I don't know how I could get in if I wanted to
open the file exclusively.
Nov 12 '05 #8

P: n/a
MFS 43 wrote:
You're correct.
<trumpet method=blow owner=me>
Of course!!!
</trumpet>
I have redone the Security Wizard and the database seems secure now but I can't
open the program by clicking on the MDB file OR by opening access and then
choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the
MDW file. This is OK but then I don't know how I could get in if I wanted to
open the file exclusively.


Isn't there a /excl or something command line argument? You could put
that into a shortcut.

--
Error reading sig - A)bort R)etry I)nfluence with large hammer
Nov 12 '05 #9

P: n/a
MFS 43 wrote:
You're correct.
<trumpet method=blow owner=me>
Of course!!!
</trumpet>
I have redone the Security Wizard and the database seems secure now but I can't
open the program by clicking on the MDB file OR by opening access and then
choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the
MDW file. This is OK but then I don't know how I could get in if I wanted to
open the file exclusively.


Isn't there a /excl or something command line argument? You could put
that into a shortcut.

--
Error reading sig - A)bort R)etry I)nfluence with large hammer
Nov 12 '05 #10

P: n/a
Read very carefully, study very carefull, and experiment with securing
copies of any worthwhile work. There is no "filler" in that Security FAQ,
and missing or misreading a single step can result in (1) a database so
insecure that anyone can get in or (2) a database so secure that even you
can't get it. You've hit both extremes... keep at it.

But, bear in mind that for US$150 or less, you can get software that will
de-secure an Access database, so don't trust it if the user will want it
that badly.

Larry Linson
Microsoft Access MVP

"MFS 43" <mf***@aol.com> wrote in message
news:20***************************@mb-m17.aol.com...
I have redone the Security Wizard and the database seems VERY secure now but I can't open the program by clicking on the MDB file OR by opening access and then choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the MDW file. This is OK but then I don't know how I could get in if I wanted to open the file exclusively.

Nov 12 '05 #11

P: n/a
Read very carefully, study very carefull, and experiment with securing
copies of any worthwhile work. There is no "filler" in that Security FAQ,
and missing or misreading a single step can result in (1) a database so
insecure that anyone can get in or (2) a database so secure that even you
can't get it. You've hit both extremes... keep at it.

But, bear in mind that for US$150 or less, you can get software that will
de-secure an Access database, so don't trust it if the user will want it
that badly.

Larry Linson
Microsoft Access MVP

"MFS 43" <mf***@aol.com> wrote in message
news:20***************************@mb-m17.aol.com...
I have redone the Security Wizard and the database seems VERY secure now but I can't open the program by clicking on the MDB file OR by opening access and then choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the MDW file. This is OK but then I don't know how I could get in if I wanted to open the file exclusively.

Nov 12 '05 #12

P: n/a
"MFS 43" <mf***@aol.com> wrote in message
news:20***************************@mb-m17.aol.com...
I have redone the Security Wizard and the database seems VERY secure now but I can't open the program by clicking on the MDB file OR by opening access and then choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the MDW file. This is OK but then I don't know how I could get in if I wanted to open the file exclusively.


You are now using the "non-secure" system.mdw as your default workgroup.
If you want login opportunities without specifying a workgroup in the
command line then you need to use the workgroup admin utility to change
your default workgroup to the secure one.
--
I don't check the Email account attached
to this message. Send instead to...
RBrandt at Hunter dot com
Nov 12 '05 #13

P: n/a
"MFS 43" <mf***@aol.com> wrote in message
news:20***************************@mb-m17.aol.com...
I have redone the Security Wizard and the database seems VERY secure now but I can't open the program by clicking on the MDB file OR by opening access and then choosing my program. It never gives me a chance to sign in.

The way I can get in is with an icon with a commnd line option identifying the MDW file. This is OK but then I don't know how I could get in if I wanted to open the file exclusively.


You are now using the "non-secure" system.mdw as your default workgroup.
If you want login opportunities without specifying a workgroup in the
command line then you need to use the workgroup admin utility to change
your default workgroup to the secure one.
--
I don't check the Email account attached
to this message. Send instead to...
RBrandt at Hunter dot com
Nov 12 '05 #14

This discussion thread is closed

Replies have been disabled for this discussion.