By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,504 Members | 2,596 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,504 IT Pros & Developers. It's quick & easy.

Access database works for some users

P: n/a
Hi all,

I have database which the front end is installed on
c:\database\sample.mdb
and the backend on a server.

The problem i am havin is wen i set the database for user such as joe
blogs the database will work for them. But if another user logs on
such as jenny blogs the database doesn't work. It says microsoft can't
find the database file c:\database\sample.mdb. however if i replace
this database with jenny blogs logged on it will then work. but if joe
blogs logs in it won't work for him.
On some computers this works if multiple users logon. But on some it
doesn't. i have tried loggin as an administrator and tryin it that way
and setting the permissions to the database folder to be shared by all
users but still doesn't work.
Is there any solution to this?

thanks

farouq
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
fa*******@hotmail.com (Farouq) wrote in message news:<c6**************************@posting.google. com>...
Hi all,

I have database which the front end is installed on
c:\database\sample.mdb
and the backend on a server.

The problem i am havin is wen i set the database for user such as joe
blogs the database will work for them. But if another user logs on
such as jenny blogs the database doesn't work. It says microsoft can't
find the database file c:\database\sample.mdb. however if i replace
this database with jenny blogs logged on it will then work. but if joe
blogs logs in it won't work for him.


Do you have a desktop shortcut that you are using to open the database
or are you first starting Access and then opening the database from
there? If you have set up a desktop shortcut to the database and you
want the database to be accessible to all users of that machine, put
the shortcut in the 'C:\Documents and Settings\All Users\Desktop'
folder and delete it from everywhere else. It should not be in
'C:\Documents and Settings\jenny blogs\Desktop' or 'C:\Documents and
Settings\joe blogs\Desktop'.

Also be sure that the database file itself really is installed in
'c:\database\' and not in an individual user's 'database' folder (i.e.
not 'C:\Documents and Settings\jenny blogs\database' or 'C:\Documents
and Settings\All Users\Desktop\joe blogs\database'). And be sure that
the 'target' field of the shortcut points to 'c:\database\sample.mdb'
as well. Hope this helps.

Bruce
Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.