By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,677 Members | 1,136 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,677 IT Pros & Developers. It's quick & easy.

MS Access Connection Window in ADP

P: n/a
I select the server name.
I select the database on the server.
I select the option: Use Windows NT Integrated Security.
tada...It works fine. Test connection sings.

Instead, I select: Use a specific user name and password.
I enter my user name
I enter my password.
bonggggg..."Test connection failed because of an error in initializing
provider. Login failed for user "myname".
I enter my user name and password a couple dozen times to make sure I
didn't typo it.
bonggggg...

What's up with that?
lq
Nov 12 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
RE/
I select the server name.
I select the database on the server.
I select the option: Use Windows NT Integrated Security.
tada...It works fine. Test connection sings.

Instead, I select: Use a specific user name and password.
I enter my user name
I enter my password.
bonggggg..."Test connection failed because of an error in initializing
provider. Login failed for user "myname".
I enter my user name and password a couple dozen times to make sure I
didn't typo it.
bonggggg...

What's up with that?
lq


Are you running a firewall like Norton's?
That's what nailed my for a few days until somebody finally suggested
that I check to see if the firewall was intercepting the logon request.

Something about another entity that's not named SQL Server but works on it's
behalf...
--
PeteCresswell
Nov 12 '05 #2

P: n/a
"Lauren Quantrell" <la*************@hotmail.com> wrote in message
news:47*************************@posting.google.co m...
I select the server name.
I select the database on the server.
I select the option: Use Windows NT Integrated Security.
tada...It works fine. Test connection sings.

Instead, I select: Use a specific user name and password.
I enter my user name
I enter my password.
bonggggg..."Test connection failed because of an error in initializing
provider. Login failed for user "myname".
I enter my user name and password a couple dozen times to make sure I
didn't typo it.
bonggggg...

What's up with that?
lq


The server may have been set up to only allow Windows authentication, which
should make the installation more secure. If you have access to Enterprise
Manager and sufficient privellages you can right-click the server and edit
the SQL Server registration properties.

But you should have a sensible reason to allow Mixed Mode Authentication.

Nov 12 '05 #3

P: n/a

"Eric Kant" <er**@kant.com> wrote in message
news:c5**********@hercules.btinternet.com...
"Lauren Quantrell" <la*************@hotmail.com> wrote in message
news:47*************************@posting.google.co m...
I select the server name.
I select the database on the server.
I select the option: Use Windows NT Integrated Security.
tada...It works fine. Test connection sings.

Instead, I select: Use a specific user name and password.
I enter my user name
I enter my password.
bonggggg..."Test connection failed because of an error in initializing
provider. Login failed for user "myname".
I enter my user name and password a couple dozen times to make sure I
didn't typo it.
bonggggg...

What's up with that?
lq
The server may have been set up to only allow Windows authentication,

which should make the installation more secure. If you have access to Enterprise Manager and sufficient privellages you can right-click the server and edit
the SQL Server registration properties.

But you should have a sensible reason to allow Mixed Mode Authentication.


Unreserved apology for the horrendous misspelling of "privileges ".

Erik
Nov 12 '05 #4

P: n/a
Erik,
I checked and it's set up to accept SQL Server and Windows Authentication.
lq
"Eric Kant" <er**@kant.com> wrote in message news:<c5**********@hercules.btinternet.com>...
"Lauren Quantrell" <la*************@hotmail.com> wrote in message
news:47*************************@posting.google.co m...
I select the server name.
I select the database on the server.
I select the option: Use Windows NT Integrated Security.
tada...It works fine. Test connection sings.

Instead, I select: Use a specific user name and password.
I enter my user name
I enter my password.
bonggggg..."Test connection failed because of an error in initializing
provider. Login failed for user "myname".
I enter my user name and password a couple dozen times to make sure I
didn't typo it.
bonggggg...

What's up with that?
lq


The server may have been set up to only allow Windows authentication, which
should make the installation more secure. If you have access to Enterprise
Manager and sufficient privellages you can right-click the server and edit
the SQL Server registration properties.

But you should have a sensible reason to allow Mixed Mode Authentication.

Nov 12 '05 #5

P: n/a

"Lauren Quantrell" <la*************@hotmail.com> wrote in message
news:47**************************@posting.google.c om...
Erik,
I checked and it's set up to accept SQL Server and Windows Authentication.
lq


And can you see that login using Enterprise Manager (look under
security>logins)? If so, you should be able to start Enterprise Manager
with that login and password and if that login has permissions for the
database in question it should be able to read tables or run stored
procedures.

Fletcher
Nov 12 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.