By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,148 Members | 759 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,148 IT Pros & Developers. It's quick & easy.

Problem witth Combo Box To View from Linked Server Database

P: n/a
I have an Access application linked to a SQL Server 2000 database
using ODBC. Call this database/server pair DB1

Part of the app needs to link to another local 2000 server to get data
from another application database. Call it DB2

I have made a view in DB1 that brings in the data from DB2. I then
link the view to the Access app. I have created a linked server login
between the two DBs (call it appuser) so calls to the view can get the
data.

I can open the view from Access and see all the data. I can also
create a query and see all the data. However when I create a combo
box in my application and try to click on it, I get the following
error message:

----
ODBC Call Failed

[Microsoft][ODBC SQL Server Driver][SQL Server]Access to the remote
server is denied because no login-mapping exists (#7416)
----

What am I missing?
Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
If I understand you correctly, you created a linked server in Sql Server
to link DB2 to DB1 and created a view in DB1 which references data from
DB2 and are linking to this view in DB1 from Access. If this is the
case, then how about just creating the view directly in DB2? If you
need to push data to DB2 from DB1, use stored procedures which you can
manipulate from Access. I always avoid linking to something that is
already linked. Always try to link directly to the source.

Rich

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 12 '05 #2

P: n/a
I see your point, but it still doesn't explain the behavior.

More info that I have come up with.

If I create an identical combo box on the form, I have the same
problem. However if I create a new form and create a new combo box
with the same datasource, I do not get the problem.

Is the form corrupted or something?

Thanks
Nov 12 '05 #3

P: n/a
OK I was able to get this to work.

I pulled an older copy of the Access app and connected the views again
and created the combo box and it worked.

I am still not sure what the problem was.
Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.