By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,098 Members | 1,131 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,098 IT Pros & Developers. It's quick & easy.

Input limit in queries...

P: n/a
Hi...

If I run one of my queries which prompts for input of type memo, and I paste
a chunk of text into the box, it doesn't matter how big the text is, if it's
more than 206 characters, it truncates the string. It also does the same
thing if I try to run the query as a stored procedure through PHP, though in
this case it allows 283 characters.
If I run the query as a normal update query using PHP, I can update
thousands of characters.

Anyone know what's going on?

It's Access 2002 with the latest Jet service pack.

Plankmeister.

--

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
The Plankmeister,
Jet databases define text colums as a max length of 255 characters.
Everything after that is ignored. Memo is not a text datatype but an
embedded object capable of storing 64,000 characters. You are running into
the limits of the length of a text column in a Jet database. If possible,
try using MSDE or some other data engine that supports wider text columns.

"The Plankmeister" <pl******************@hotmail.com> wrote in message
news:40***********************@dread16.news.tele.d k...
Hi...

If I run one of my queries which prompts for input of type memo, and I paste a chunk of text into the box, it doesn't matter how big the text is, if it's more than 206 characters, it truncates the string. It also does the same
thing if I try to run the query as a stored procedure through PHP, though in this case it allows 283 characters.
If I run the query as a normal update query using PHP, I can update
thousands of characters.

Anyone know what's going on?

It's Access 2002 with the latest Jet service pack.

Plankmeister.

--

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.