By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,324 Members | 1,967 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,324 IT Pros & Developers. It's quick & easy.

Form (Stop moving to new record)

P: n/a
DD
Hi
I have built some forms and made my own forward and back buttons and
removed all the Access default navigation buttons..however now when
you come to the last field and tab,, it opens a new record. rather
than staying with the same..
I have tried various things and have had no success

any help please
DD
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
>I have built some forms and made my own forward and back buttons and
removed all the Access default navigation buttons..however now when
you come to the last field and tab,, it opens a new record. rather
than staying with the same..


For the last control on the record, enter the following code for Event/On Exit:
Private Sub MaxSumHours_Exit(Cancel As Integer)
DoCmd.GoToControl "FirstControlOfYourForm"
' Comment:prevents tabbing into the next record
End Sub
This will cause the control to go back to the start of your form, or wherever
else you want it to go. Pete
Nov 12 '05 #2

P: n/a
da**********@bigpond.com.au (DD) wrote in message news:<14**************************@posting.google. com>...
Hi
I have built some forms and made my own forward and back buttons and
removed all the Access default navigation buttons..however now when
you come to the last field and tab,, it opens a new record. rather
than staying with the same..
I have tried various things and have had no success

any help please
DD


Open the form's properties (View, Properties) and click on the Other tab.

Set the "Cycle" property to "Current Record".
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.