By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
444,153 Members | 2,581 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 444,153 IT Pros & Developers. It's quick & easy.

problem with Unicode, HTML, and MS Access

P: n/a
Hi,

Could someone help me with my problem as follows:
I have a big MS Access database full of sentences (Vietnamese
proverbs) in Unicode.
Now when I try to search for sentences (that contain some string) to
display on a webpage, then what I see on the webpage is not what I see
in the database table.
For example, when I look in my database: Ăn cam ngồi
gốc cy cam
but what displayed on the webpage is: Ăn cam ng?i g?c c?y cam
It's so disappointing. Could you tell me how to fix this problem with
or without having to reformat the whole table which is very big, the
result of 3 years of work.

Thank you very much,

Thuan
bu*****@yahoo.com
Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Thuan Do wrote:
Hi,

Could someone help me with my problem as follows:
I have a big MS Access database full of sentences (Vietnamese
proverbs) in Unicode.
Now when I try to search for sentences (that contain some string) to
display on a webpage, then what I see on the webpage is not what I see
in the database table.
For example, when I look in my database: Ăn cam ngồi
gốc cy cam
but what displayed on the webpage is: Ăn cam ng?i g?c c?y cam
It's so disappointing. Could you tell me how to fix this problem with
or without having to reformat the whole table which is very big, the
result of 3 years of work.

Thank you very much,


You might want to look at the encoding of the web page, e.g. at the top
there's something like <meta http-equiv="Content-Type"
content="text/html;charset=ISO-8859-1"> and make sure the charset
matches what you have in the database.
Nov 12 '05 #2

P: n/a
Trevor Best <nospam@localhost> wrote in message news:<40***********************@auth.uk.news.easyn et.net>...

You might want to look at the encoding of the web page, e.g. at the top
there's something like <meta http-equiv="Content-Type"
content="text/html;charset=ISO-8859-1"> and make sure the charset
matches what you have in the database.


Hi, thank you for your help, but it did not work. I found a way to
work around this problem, and I want to share it here:

1. change my big table into several small tables 1,2,3,4... so that
the frontpage express can deal with (later)
2. open table1,
3. Select all records, copy
4. paste it to Notepad (to get rid of "table" format and change them
into '\tab' character and '\n' character only)
5. copy all from Notepad to Frontpage Express
6. click on HTML button in Frontpage Express
7. Copy all things in that HTML (source of webpage) and paste them
into Wordpad
9. Delete all HTML tags by using Replace All
Reformat that file to make it correctly representing a database table
(using your mouse and delete button, and space bar when necessary)
10. Save it as a text file
11. From the database, use import to get this file to append to my
(empty at the beginning) table. Use the auto numbering

That's it. :-) The format now is correct now when I get the fields'
data to display on my webpage. Even though it's not very nice looking
when I see the data inside the table of my database: full of
characters like #&0734; etc..
Have a nice day,

Thuan
Nov 12 '05 #3

P: n/a
Thuan Do wrote:

That's it. :-) The format now is correct now when I get the fields'
data to display on my webpage. Even though it's not very nice looking
when I see the data inside the table of my database: full of
characters like #&0734; etc..
Have a nice day,


Interesting it seems to translate both ways, glad you got it sorted.
Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.