By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,231 Members | 1,636 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,231 IT Pros & Developers. It's quick & easy.

Fails to navigate to the proper record WITHOUT a MsgBox

P: n/a
CFW
I use the below code to move to the selected record in a list box to
that record in another form:

DoCmd.OpenForm "frmWorksheet", acNormal, , , acFormEdit,
acWindowNormal
rst.CursorLocation = adUseClient
rst.Open "qry_frmWorksheet", CurrentProject.Connection,
adOpenKeyset, adLockOptimistic
MsgBox strCremationNumber
rst.Find "[CremationNumber] = " &
str(Nz(strCremationNumber, 0)) ' strCremationNumber is set to
lst.Column(0) - the list box's bound column
If Not rst.EOF Then Forms!frmWorksheet.Bookmark =
rst.Bookmark Else MsgBox "EOF"

Problem is, without the MsgBox popping up before the FIND, it just
opens the second form to the first record. With the MsgBox pop up -
it works! I have had this same problem using other methods to
navigate to the same record on another form! Can someone help? I can
use any method that consistently works but I often need to choose a
record in a list box on one form and have another form open up with
that record as the current record. I am working MOSTLY with .adp
projects. THANKS!!
Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.