By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,688 Members | 1,878 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,688 IT Pros & Developers. It's quick & easy.

Just converted to A2002, querries not working - please help

P: n/a
Hello:
Thanks for reading this. We just converted to A2002 and some of my
querries have stopped working and I can't figure out why.

Basically, anything with a "NOT" is not working.

For example:

select * from b321bl where stdverifyby <> "demonstration"

does not work. The records with "demonstration" are still there.

Also tried....

select * from b321bl where stdverifyby NOT like "demo*"

dosen't work either.

I also tried.....
<> 'demonstration'
NOT = 'demonstration'
NOT LIKE 'demo*'

So, I tried it with double " and single '

This only happened when we switched to A2002. Before that, the querries
were fine.

Has something changed, or were my original querries incorrectly
structured and A2002 just dosen't like them?

Thanks for any advise.

PS: stdverifyby is a "varchar 50"

Richard Hollingsworth

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Nevermind, I found the problem. It wasn't the text delimiters that were
the problem.

I was actually tyring to do 2 comparrisons using OR and that was not
working. I had to change the OR to AND (don't understand why) and it
worked.

Go fugure.

Original SQL:

SELECT *
FROM B321BL
WHERE (NOT (STDVerifyBy = 'demonstration')) OR (NOT (STDVerifyBy =
'analysis'))

changed to:

SELECT *
FROM B321BL
WHERE (NOT (STDVerifyBy = 'demonstration')) AND (NOT (STDVerifyBy =
'analysis'))

and it worked fine.

Thanks,
Richard


Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.