By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,136 Members | 1,742 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,136 IT Pros & Developers. It's quick & easy.

wrong order of images in printing reports

P: n/a
salamo alikom,
i'm working with arachaeological sites database and i want to show the
picture of each site in its report.every thing goes fine in the
preview of the reports(on screen).But in printing the images are
printrd in the report with wrong arder i.e.:2nd image is printed in
the page of the 1rst site,3rd image is printed in the page of the 2nd
site,etc.
the images are on the server and their pathes are saved in a field in
the record source table of the report.and here is the VBA code i used:
Private Sub Report_Page()
On Error Resume Next
If Me.image_path <> "" Then
Image29.Requery
Me.Image29.Picture = Me.image_path
Image29.Requery
Else
MsgBox "This site doesn't have image"
End If
End Sub

any help is appreciated
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Without more information on what data you have and how the report is
organized, this is something of a guess, but the "Page" event seems an
unusal place to put the code. All my reports associate pictures with a
record, and that would mean similar code would be placed in the OnPrint
event of the Detail Section.

Larry Linson
Microsoft Access MVP

"marwa mohamed" <ma*********@hotmail.com> wrote in message
news:76**************************@posting.google.c om...
salamo alikom,
i'm working with arachaeological sites database and i want to show the
picture of each site in its report.every thing goes fine in the
preview of the reports(on screen).But in printing the images are
printrd in the report with wrong arder i.e.:2nd image is printed in
the page of the 1rst site,3rd image is printed in the page of the 2nd
site,etc.
the images are on the server and their pathes are saved in a field in
the record source table of the report.and here is the VBA code i used:
Private Sub Report_Page()
On Error Resume Next
If Me.image_path <> "" Then
Image29.Requery
Me.Image29.Picture = Me.image_path
Image29.Requery
Else
MsgBox "This site doesn't have image"
End If
End Sub

any help is appreciated

Nov 12 '05 #2

P: n/a

salamo alikom
First thanks a lot for your reply .Second I actually followed the
directions of the help of Microsoft AccessXP and I was advised by a
developer through "developersdex" site to move my code to OnFormat event
of the Details Section and it worked perfect when i did that.

For who can read arabic this is a useful link:
http://hayah.amrkhaled.net/modules.p...showpage&pid=3

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.