By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,500 Members | 830 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,500 IT Pros & Developers. It's quick & easy.

how do i change a field to greater then 255 characters

P: n/a
I am importing a table from Informix into Access XP via an ODBC
connection. In one of the fields, I will need it to allow 4000
characters. In Access help, it shows the data type can be changed to
"memo" and that will allow up to 65,535 characters. After importing
the table, I checked the data type and it automatically was set to
memo, but with the 255 character limitation. When I attempt to go
over 255, it will not allow it. Does anyone know how to change the
field size?

Thanks,
Adam
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
A Memo field has no size to set. It holds an arbitrary number of characters
up to 65,535 as you say. Where do you see anything saying the size is 255?
Now, it is entirely possible that the field will hold more than 255
characters, but the import is failing to transfer them, so if you're just
looking at how many characters you got, that could be it.

I've seen this issue come up before with ODBC because if the column data type
on the server is varchar, then Access/Jet maps sees that as being the MS Jet
Text type, and that is limited to 255 characters, so that's all you can read
from the linked field. Again, this is a problem with how Access treats the
ODBC data it is reading, not the Access table it's writing to.

If this is your problem, you might be able to fix it by using a view on the
server side that converts the varchar data to the TEXT (ANSI) data type which
ODBC will treat as a MEMO and not limit the data to 255 characters.

On 27 Jan 2004 15:24:53 -0800, fa*****@netzero.net (Adam) wrote:
I am importing a table from Informix into Access XP via an ODBC
connection. In one of the fields, I will need it to allow 4000
characters. In Access help, it shows the data type can be changed to
"memo" and that will allow up to 65,535 characters. After importing
the table, I checked the data type and it automatically was set to
memo, but with the 255 character limitation. When I attempt to go
over 255, it will not allow it. Does anyone know how to change the
field size?

Thanks,
Adam


Nov 12 '05 #2

P: n/a
Steve,
Thanks for your reply. I actually found the problem to be happening
when I run an SQL query in Access. When I view the complete table,
the fields are not maxed at 255. After the query, they are. Do you
have any thoughts on this?

Thanks,
Adam
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.