By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,992 Members | 934 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,992 IT Pros & Developers. It's quick & easy.

No $ for Currency fields

P: n/a
I have several fields in my database specified as Currency data type. Is there a
way globally to set these fields not to display the dollar sign?

Thanks!

Melissa
Nov 12 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
You may try removing the symbol from your local settings in Control Panel.
However, a better option, depending on your version, may be to use a Number
datatype and in the bottom where it says Field Size, choose Decimal. Another
option may be to use the Format option to remove it. This will still give
you the Currency datatype and its precision, but without the character.

--
Wayne Morgan
MS Access MVP
"Melissa" <mw*****@earthlink.net> wrote in message
news:sg****************@newsread2.news.atl.earthli nk.net...
I have several fields in my database specified as Currency data type. Is there a way globally to set these fields not to display the dollar sign?

Thanks!

Melissa

Nov 12 '05 #2

P: n/a
Melissa wrote:
I have several fields in my database specified as Currency data type. Is there a
way globally to set these fields not to display the dollar sign?

Thanks!

Melissa


The Currency Datatype is different than Currency Formatting.
Formatting affects only how the field is displayed.
Retain the Field Datatype as Currency, but set the format to Fixed with
2 decimals,
or use

#,###.00;-#,###.00;0.00

in the format field if you wish the comma as a thousands separator and
0.00 if the field is Zero.
See Access Help regarding
Format + Currency and Number Datatypes
for additional possibilities.
--
Fred
Please reply only to this newsgroup.
I do not respond to personal e-mail.
Nov 12 '05 #3

P: n/a
On Wed, 17 Dec 2003 20:57:24 GMT in comp.databases.ms-access, "Wayne
Morgan" <co***************************@hotmail.com> wrote:
You may try removing the symbol from your local settings in Control Panel.
However, a better option, depending on your version, may be to use a Number
datatype and in the bottom where it says Field Size, choose Decimal. Another
option may be to use the Format option to remove it. This will still give
you the Currency datatype and its precision, but without the character.


<rant>

IMHO there should be a global option to turn this off, it's a right
royal PITA to have it displayed as default, particularly as every app
I've ever written in Access that handles money is multi currency.
When exporting to other formats I have to resort to cdbl() or
something in a query to stop the currency symbol from being exported
also. As far as I'm concerned when exporting to another format there
should be no formatting of any kind unless explicitly specified.

</rant>

p.s. sorry for tagging on your post Wayne, my rant isn't aimed at you.

--
A)bort, R)etry, I)nfluence with large hammer.
Nov 12 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.