By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,846 Members | 1,631 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,846 IT Pros & Developers. It's quick & easy.

Conversion from 2.0 to 2000: Admin has no Administer rights on forms

P: n/a
Hi all.

I'm having a problem that's driving me nuts. I am not familiar with
Access, but I have read the FAQ, searched google, read the Access
Security FAQ, and looked at the Access Web, to no avail. Briefly, the
problem is this:

I'm having an old Access 2.0 database that I want to convert to Access
2000 on a different computer. The reason why the new database is on a
different computer is that the old database runs under Windows 95a (no
kidding!) on a 300 MHz Celeron with 32 MB of RAM. The disk has about 50
Megs of free space. I don't want to try to install Access 2000 on that
machine. :-) The database is split into several MDB files, a few of
which contain only tables, but one of which contains all the forms and
VBA code.

I can convert the data-containing tables just fine, no problems there.
However, the forms-containing tables give me problems. Access 2000 told
me that I needed a lot of permissions simply to open the database. I
have joined the workgroup, using the original workgroup file. The
workgroup admin tells me that I have joined the workgroup successfully,
but I still get the error message.

I'd very much like to make a new workgroup file, but no-one knows the
values for the WID etc of the original workgroup file, and I wouldn't
know how to recover them from that file.

My next try was to try to "de-secure" the database as per the Access
Security FAQ. That means granting all permissions to the Users group and
the Admin account, putting Admin back in Administrators, removing its
password, and (optionally) transfer ownership to Admin.

The Admin user is in the Admins group. As far as I can see, the owner of
the forms is listed as "<Unknown>", and the Administer rights have been
revoked from the Administrator. (In fact, no user or group has
Administer rights.) When I try to add these rights back, the form that
appears tells me that the "current user" is "Administrator", but for
some reason, I get a "permission denied" error when I try to give
Administer rights to the Administrator user or the Administrators group.
I also can't transfer the ownership, which fails with a similar
message. (I have also looked to make sure that the current user is not
in fact "Administrator " with a trailing space or something, but
apparently this is not the case.)

All the above user and group information is translated from German. The
Admin is "Administrator" and the Admins group is "Administratoren".

I have only one System.mda file (*not* a .mdw file), but I don't really
know whether this is the one that's being used. Everything that I did
seems to be consistent with that assumption, though, and I have found no
..ini file that told me otherwise.

The forms, unfortunately, together with their associated VBA, contain a
lot of business logic, so recreating the forms and macros from scratch
is out of the question. I'd be happy, though, if I could somehow recover
the forms and VBA code through some kind of "save as" feature.

Please help me. Otherwise, I'll either jump out of the window or tear
all my hair out :-)

Oh yes, and happy Nikolaus to you all :-) (Is that known outside Germany?)

Stephan
--
Stephan Neuhaus
ADC IT-Security GmbH - 66111 Saarbrücken

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Stephan Neuhaus wrote:
Hi all.


I've experimented a bit. Importing the database objects into a new
database did the trick. The objects are now unsecured and I can
manipulate them at will.

Fun,

Stephan
--
Stephan Neuhaus
University of the Saarland, Department of Computer Science
Experimental Software Security at the Chair of Software Engineering
Web: http://www.st.cs.uni-sb.de/~neuhaus

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.