By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,793 Members | 1,269 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,793 IT Pros & Developers. It's quick & easy.

Still getting duplicate Autonumbers

P: n/a
Hi there,

After compacting/repairing a db, I was getting duplicate autonumbers.

According to MS KB article
http://support.microsoft.com/default.aspx?kbid=257408

This should be fixed with a Jet service pack.

The mentioned SP6 is apparently not available, but I found SP8. Have now
applied SP8 (I checked msjet40.dll and it's now the new version), restarted
windows, compacted and repaired the DB 6 times, but I still get duplicate
autonumbers.

It's not a linked database. I have tried a PC with winXp and access 2000,
and a pc with winXP and AccessXp.

It's an Access2000 database.

/jim
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Jim, what you have done is correct, i.e. applying the latest JET service
pack.

I'm not seeing this problem (though reading of others who do) so perhaps you
could try recreating:

1. Run the code in this link:
http://allenbrowne.com/ser-40.html
It resets the Seed of the autonumbers that have problems.

2. Create a new (blank) database.

3. Immediately, turn off the Name AutoCorrect options under:
Tools | Options | General.

4. Into this new database that was created under JET 4 SP8 and with the Name
AutoCorrect options disabled, import everything:
File | Get External | Import

Let us know if it solves the issue.

--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org..

"Jim Andersen" <ji*****@officeconsult.dk> wrote in message
news:bq**********@sunsite.dk...
Hi there,

After compacting/repairing a db, I was getting duplicate autonumbers.

According to MS KB article
http://support.microsoft.com/default.aspx?kbid=257408

This should be fixed with a Jet service pack.

The mentioned SP6 is apparently not available, but I found SP8. Have now
applied SP8 (I checked msjet40.dll and it's now the new version), restarted windows, compacted and repaired the DB 6 times, but I still get duplicate
autonumbers.

It's not a linked database. I have tried a PC with winXp and access 2000,
and a pc with winXP and AccessXp.

It's an Access2000 database.

Nov 12 '05 #2

P: n/a
Allen Browne wrote:
I'm not seeing this problem (though reading of others who do) so
perhaps you could try recreating:

1. Run the code in this link:
http://allenbrowne.com/ser-40.html
It resets the Seed of the autonumbers that have problems.
I used a "insert into" query with a new (max+1) autonumber.
4. Into this new database that was created under JET 4 SP8 and with
the Name AutoCorrect options disabled, import everything:


Unfortunaltely it doesn't import permissions, so I leave it in the old db,
cross my fingers, and hope it works ok

/jim
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.