By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,838 Members | 2,222 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,838 IT Pros & Developers. It's quick & easy.

How do you show leading zero in exported .csv file?

P: n/a
Hello,

I'm trying to export a query containing contact information, including a
[zipcode] field. Some zip codes have one or two leading zeros, for example,
San Juan, PR (00927) and Springfield, MA (01104). When I export to a comma
separated value (.csv) file, the zip code for San Juan becomes "927" and for
Springfield becomes "1104". How can I prevent the leading zero(s) from being
trimmed in the exported .csv file?

Because the table contains both USA and Canadian addresses, the underlying
[PostalCode] field in the original table is a text value. Does that make a
difference?

I have observed that the leading zero remains in records where the data in
that field contains zip+4 information, for example, "01104-0430".

Thanks,
Joshua Ammann
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Your export specification has identified the postal code column as a
numeric column and is stripping off the leading zeros. You'll need to
change the export spec to have that column a text data type. To get
to the export/import specifications (if you don't know):

File > Get External Data > Import

highlight a text file (any one, we're just using it to open the Text
import wizard) - when the import wizard dialog box appears click the
advanced button - when the specifications dialog box appears click the
Specs command button - select the specification name that has the name
of the query you were trying to export - look for the PostalCode
column definition in the specifications dialog box subform & change
its data type to Text.

HTH,

MGFoster:::mgf
Oakland, CA (USA)
-----BEGIN PGP SIGNATURE-----
Version: PGP for Personal Privacy 5.0
Charset: noconv

iQA/AwUBP8LCFoechKqOuFEgEQKjOgCcD28q2HnI2Xjp9Wk6W90A0n kG0VsAn3Qj
cPqe55XW2zpfdd3UUmYXFp5l
=77Iv
-----END PGP SIGNATURE-----

Joshua Ammann wrote:
Hello,

I'm trying to export a query containing contact information, including a
[zipcode] field. Some zip codes have one or two leading zeros, for example,
San Juan, PR (00927) and Springfield, MA (01104). When I export to a comma
separated value (.csv) file, the zip code for San Juan becomes "927" and for
Springfield becomes "1104". How can I prevent the leading zero(s) from being
trimmed in the exported .csv file?

Because the table contains both USA and Canadian addresses, the underlying
[PostalCode] field in the original table is a text value. Does that make a
difference?

I have observed that the leading zero remains in records where the data in
that field contains zip+4 information, for example, "01104-0430".

Thanks,
Joshua Ammann


Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.