By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,949 Members | 1,455 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,949 IT Pros & Developers. It's quick & easy.

strange behavior with unicode compression

P: n/a
I am attempting to set the UnicodeCompression property via code. The
following line "appears" to work:

tdf.Fields("State").Properties("UnicodeCompression ").Value =
True

I can see the boolean in the property sheet change from No to Yes.
However, the behavior has not changed at all. It still behaves as
though it were set to No. When I change the boolean in the property
sheet GUI it behaves as expected. Any thoughts?

TIA

Bill
Nov 12 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a

Bill,

On 7 Nov 2003 08:08:28 -0800, wg****@draper.com (Bill Grigg) wrote in
comp.databases.ms-access:
I can see the boolean in the property sheet change from No to Yes.
However, the behavior has not changed at all. It still behaves as
though it were set to No. When I change the boolean in the property
sheet GUI it behaves as expected. Any thoughts?


Can you be a little more specific about what 'behavior' you are using
for your testing here? Are you checking the contents of this text
field in a hex editor to see whether unicode compression is enforced?
Are you checking file size of the db before and after? What test are
you referring to when you conclude that the unicode compression is not
working when the property is set through code?

Peter Miller
__________________________________________________ __________
PK Solutions -- Data Recovery for Microsoft Access/Jet/SQL
Free quotes, Guaranteed lowest prices and best results
www.pksolutions.com 1.866.FILE.FIX 1.760.476.9051
Nov 12 '05 #2

P: n/a
TC

"Peter Miller" <pm*****@pksolutions.com> wrote in message
news:0b********************************@4ax.com...

Bill,

On 7 Nov 2003 08:08:28 -0800, wg****@draper.com (Bill Grigg) wrote in
comp.databases.ms-access:
I can see the boolean in the property sheet change from No to Yes.
However, the behavior has not changed at all. It still behaves as
though it were set to No. When I change the boolean in the property
sheet GUI it behaves as expected. Any thoughts?


Can you be a little more specific about what 'behavior' you are using
for your testing here? Are you checking the contents of this text
field in a hex editor to see whether unicode compression is enforced?
Are you checking file size of the db before and after? What test are
you referring to when you conclude that the unicode compression is not
working when the property is set through code?

And, is it by chance a memo field?

TC

Nov 12 '05 #3

P: n/a

Sorry, I should have given a little more detail. It is a text field. The
behavior has to do with what appears to spaces padded on the right to
fill out the field to whatever size is specified. More specifically, I
noticed that when Unicode Compression is off, and I have a text field of
say 50 characters, and I enter lets say 3 characters into the field that
it is padded with 47 spaces on the right. I can try to delete the spaces
in lets say table view, but they will not go away. This behavior does
not occur when Unicode Compression is turned on.
Bill

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 12 '05 #4

P: n/a
Well the original problem has been solved. I still do not understand
the behavior described below. What I am doing is updating Access
tables and queries from Visio Enterprise edition where I create ER
diagrams and then either generate or update the Access database from
Visio. After googling around a bit I changed my text field types (in
Visio) from CHAR to TEXT. The padded blank problem is solved, and the
Unicode Compression is still not enabled. The bottom line seems to be
that there are Access table properties that are unviewable from the
property sheet, and unprogrammable from VBA.

Bill
Bill Grigg <wg****@draper.com> wrote in message news:<3f*********************@news.frii.net>...
Sorry, I should have given a little more detail. It is a text field. The
behavior has to do with what appears to spaces padded on the right to
fill out the field to whatever size is specified. More specifically, I
noticed that when Unicode Compression is off, and I have a text field of
say 50 characters, and I enter lets say 3 characters into the field that
it is padded with 47 spaces on the right. I can try to delete the spaces
in lets say table view, but they will not go away. This behavior does
not occur when Unicode Compression is turned on.
Bill

Nov 12 '05 #5

P: n/a
TC
Well, presumeably CHAR is a >fixed length< field in Visio?

TC
"Bill Grigg" <wg****@draper.com> wrote in message
news:d7**************************@posting.google.c om...
Well the original problem has been solved. I still do not understand
the behavior described below. What I am doing is updating Access
tables and queries from Visio Enterprise edition where I create ER
diagrams and then either generate or update the Access database from
Visio. After googling around a bit I changed my text field types (in
Visio) from CHAR to TEXT. The padded blank problem is solved, and the
Unicode Compression is still not enabled. The bottom line seems to be
that there are Access table properties that are unviewable from the
property sheet, and unprogrammable from VBA.

Bill
Bill Grigg <wg****@draper.com> wrote in message

news:<3f*********************@news.frii.net>...
Sorry, I should have given a little more detail. It is a text field. The
behavior has to do with what appears to spaces padded on the right to
fill out the field to whatever size is specified. More specifically, I
noticed that when Unicode Compression is off, and I have a text field of
say 50 characters, and I enter lets say 3 characters into the field that
it is padded with 47 spaces on the right. I can try to delete the spaces
in lets say table view, but they will not go away. This behavior does
not occur when Unicode Compression is turned on.
Bill

Nov 12 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.