470,596 Members | 1,356 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,596 developers. It's quick & easy.

Add "ALL" to combo shows no records

Access 2000

I am trying to add "ALL" to a combo that is used to filter a query.
When "ALL" is selected no records show instead of ALL records showing.

I have setup a "dummy" table (tblDum) with 1 field (txtDummy,
Integer)with 1 record that has a "0" entered.

The field that is being filtered is an Integer type.

Here is the rowsource for the combo:

SELECT tblProviders.ProviderID, tblProviders.ProviderName FROM
tblProviders UNION Select 0 as AllChoice , "(All)" as Bogus From
tblDum;

Any and ALL suggestions are truly appreciated!

Thanks
Dale
Nov 12 '05 #1
2 2313
mt****@yadtel.net (Dale Ring) wrote in
news:d5**************************@posting.google.c om:
Access 2000

I am trying to add "ALL" to a combo that is used to filter a
query. When "ALL" is selected no records show instead of ALL
records showing.

I have setup a "dummy" table (tblDum) with 1 field (txtDummy,
Integer)with 1 record that has a "0" entered.

The field that is being filtered is an Integer type.

Here is the rowsource for the combo:

SELECT tblProviders.ProviderID, tblProviders.ProviderName FROM
tblProviders UNION Select 0 as AllChoice , "(All)" as Bogus
From tblDum;

Any and ALL suggestions are truly appreciated!
There is no problem here, this part works fine. It's what you are
doing when the "All" option is selected that needs to be changed,
but you didn't post that part of your design.

What is in the AfterUpdate Event of your combo? That's what we need
to diagnose your problem.

Bob Q

Thanks
Dale


Nov 12 '05 #2
Dale,
sounds like this will solve your problem...

http://www.mvps.org/access/forms/frm0043.htm
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by bhdvir | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.