By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,775 Members | 2,658 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,775 IT Pros & Developers. It's quick & easy.

Space between fields

P: n/a
Frinds, I am creating a form which exports and prints data to a Word
file named FORM1.
This word file has some fields which I have bookmarked and one of its
fields is named NAME.

The code that export the Access data to my bookmarked Word fields is:

..Selection.Goto wdGoToBookmark, Name:="NAME"
..Selection.TypeText rstCases!FIRSTName & " " & rstCases!LASTName

You will notice that my code exports two Access fields named FIRSTName
and LASTName.

Two are the problem I am having.
1) Whan I export the data, the first and last name are concatenated. I
would like to give a space between the first and last name. I have
tried to add a comma (,) in between the " " but it does not work.

2) My second problem is despite my Access fields are simply text field
with a CAPITOL LETTER format (>) when I export the data, it is shown
in small letters.

Any help?

Thanks.
Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
I have found problems in access calling fields "Name". Suggest using
"WholeName" or something similar.

Try
Dim WholeName as String
WholeName = UCase(rstCases!FIRSTName & ", " & rstCases!LASTName)
That should do the concatenation and convert to upper case
Then
.Selection.TypeText WholeName

Phil
"Paolo" <jp***@tin.it> wrote in message
news:9f**************************@posting.google.c om...
Frinds, I am creating a form which exports and prints data to a Word
file named FORM1.
This word file has some fields which I have bookmarked and one of its
fields is named NAME.

The code that export the Access data to my bookmarked Word fields is:

.Selection.Goto wdGoToBookmark, Name:="NAME"
.Selection.TypeText rstCases!FIRSTName & " " & rstCases!LASTName

You will notice that my code exports two Access fields named FIRSTName
and LASTName.

Two are the problem I am having.
1) Whan I export the data, the first and last name are concatenated. I
would like to give a space between the first and last name. I have
tried to add a comma (,) in between the " " but it does not work.

2) My second problem is despite my Access fields are simply text field
with a CAPITOL LETTER format (>) when I export the data, it is shown
in small letters.

Any help?

Thanks.

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.