By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,490 Members | 897 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,490 IT Pros & Developers. It's quick & easy.

DAO problem

P: n/a
HI All,
I'm hoping someone has come across this problem b4.
I lost my hard-drive and had to re-install everything. I'm running on
W98SE, with Office XP pro (2002).
Luckily I had the latest version of my project on CD, so that was
saved, but when I try to run it on the new install, I get the
following message;
"Your BOM0809 database or project contains a missing or brocken
reference to the file "DAO3032.Dll" version 5.0"
* To ensure that your database or project works properly, you must fix
this reference.
* To learn how to fix this reference, click Help".
OK, I follow this, but when I open the Tools toolbar, the References
command is greyed out.
I never had all this hassle b4, what has gone wrong with my
installation.????
TIA for any/all ideas. (I have tried downloading and applying the
service packs 1 & 2, and also downloaded and installed MDAC 2.5, then
MDAC 2.8,?)
Stan
Nov 12 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Hmmm....this may be a windows problem. I would google around with that file
name. This is also just a shot in the dark but you may have to do something
to the effect of:

Regsvr32.exe "C:\Program Files\Common Files\Microsoft
Shared\dao\dao3032.dll"

If you hit Start->Run and type that in (or whatever the path is to the .dll
file), that might just do it. This registers the dll with windows...

"Stan" <St**@fencepost.co.nz> wrote in message
news:45********************************@4ax.com...
HI All,
I'm hoping someone has come across this problem b4.
I lost my hard-drive and had to re-install everything. I'm running on
W98SE, with Office XP pro (2002).
Luckily I had the latest version of my project on CD, so that was
saved, but when I try to run it on the new install, I get the
following message;
"Your BOM0809 database or project contains a missing or brocken
reference to the file "DAO3032.Dll" version 5.0"
* To ensure that your database or project works properly, you must fix
this reference.
* To learn how to fix this reference, click Help".
OK, I follow this, but when I open the Tools toolbar, the References
command is greyed out.
I never had all this hassle b4, what has gone wrong with my
installation.????
TIA for any/all ideas. (I have tried downloading and applying the
service packs 1 & 2, and also downloaded and installed MDAC 2.5, then
MDAC 2.8,?)
Stan

Nov 12 '05 #2

P: n/a
On Sun, 19 Oct 2003 19:17:20 -0700, "Bill" <zi*****@hotmail.com>
wrote:
Hmmm....this may be a windows problem. I would google around with that file
name. This is also just a shot in the dark but you may have to do something
to the effect of:

Regsvr32.exe "C:\Program Files\Common Files\Microsoft
Shared\dao\dao3032.dll"

If you hit Start->Run and type that in (or whatever the path is to the .dll
file), that might just do it. This registers the dll with windows...

"Stan" <St**@fencepost.co.nz> wrote in message
news:45********************************@4ax.com.. .
HI All,
I'm hoping someone has come across this problem b4.
I lost my hard-drive and had to re-install everything. I'm running on
W98SE, with Office XP pro (2002).
Luckily I had the latest version of my project on CD, so that was
saved, but when I try to run it on the new install, I get the
following message;
"Your BOM0809 database or project contains a missing or brocken
reference to the file "DAO3032.Dll" version 5.0"
* To ensure that your database or project works properly, you must fix
this reference.
* To learn how to fix this reference, click Help".
OK, I follow this, but when I open the Tools toolbar, the References
command is greyed out.
I never had all this hassle b4, what has gone wrong with my
installation.????
TIA for any/all ideas. (I have tried downloading and applying the
service packs 1 & 2, and also downloaded and installed MDAC 2.5, then
MDAC 2.8,?)
Stan

Stan again,
Thanks for your input Bill. Unfort. it didn't do the job, but a reply
was appreciated.
Nov 12 '05 #3

P: n/a
I thought MDAC was ADO, not DAO. Big difference! What happens if you
uncheck all the references to DAO in your project, close the
References window and then add the DAO 3.6 reference and recompile?
Does that work?
Nov 12 '05 #4

P: n/a
On 21 Oct 2003 09:09:29 -0700, pi********@hotmail.com (Pieter Linden)
wrote:
I thought MDAC was ADO, not DAO. Big difference! What happens if you
uncheck all the references to DAO in your project, close the
References window and then add the DAO 3.6 reference and recompile?
Does that work?


Hi Pieter,
I don't know. Somehow, the problem just "went away" I loaded an
earlier version off the cd i made, and tried that, to see if it got
the same result, and it worked fine, so I tried the latest version of
my project, and it worked fine too. ??????
Thanks for your thought anyway,
Stan
Nov 12 '05 #5

P: 1
The problem with the references being "grayed out" is due to still being in "debug mode". If you make sure to hit the "Run Reset" on the menu or the reset icon, the references will no longer be "grayed out". Or you could even just exit the project and come back in holding shift and go straight to a module and Tools-References before any code runs.
Jul 19 '06 #6

This discussion thread is closed

Replies have been disabled for this discussion.