By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,453 Members | 3,194 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,453 IT Pros & Developers. It's quick & easy.

ODBC + Access + C = problem

P: n/a
hello,
i connect to an Access DataBase thrue ODBC using C api.
nearly everything is going well : i can connect and retrieve data from the
Access.
BUT when a try to UPDATE or INSERT nothing happens in the database. i have
no error from the API.
i try to update using direct execute, execute or using a cursor.... nothing
appens.
autocommit or not.
have you any idea of what is going wrong ?

Yann Guillerm.
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
"guillerm yann" <gu***********@wanadoo.fr> wrote in message news:<bm**********@news-reader5.wanadoo.fr>...
hello,
i connect to an Access DataBase thrue ODBC using C api.
nearly everything is going well : i can connect and retrieve data from the
Access.
BUT when a try to UPDATE or INSERT nothing happens in the database. i have
no error from the API.
i try to update using direct execute, execute or using a cursor.... nothing
appens.
autocommit or not.
have you any idea of what is going wrong ?

Yann Guillerm.

Could you post some code please? Also versions, drivers etc.

Edward
--
The reading group's reading group:
http://www.bookgroup.org.uk
Nov 12 '05 #2

P: n/a
finaly i found that it was a strange configuration of the user right changed
by someone else !

sorry !

"Edward" <te********@hotmail.com> a écrit dans le message de
news:25**************************@posting.google.c om...
"guillerm yann" <gu***********@wanadoo.fr> wrote in message

news:<bm**********@news-reader5.wanadoo.fr>...
hello,
i connect to an Access DataBase thrue ODBC using C api.
nearly everything is going well : i can connect and retrieve data from the Access.
BUT when a try to UPDATE or INSERT nothing happens in the database. i have no error from the API.
i try to update using direct execute, execute or using a cursor.... nothing appens.
autocommit or not.
have you any idea of what is going wrong ?

Yann Guillerm.

Could you post some code please? Also versions, drivers etc.

Edward
--
The reading group's reading group:
http://www.bookgroup.org.uk

Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.