By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,863 Members | 879 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,863 IT Pros & Developers. It's quick & easy.

Problem with Index

P: n/a
I have an Access table that just consists of 2 columns: WordID
(Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've
used this with a number of texts and languages without any problems.
With my first Unicode Greek text, I've encountered a problem. The
first 2 words of the text are "o(doi\ du/o". Now, those obviously are
not the same words, but after I add the first, the second cannot be
added because it thinks that I am making a duplicate entry. In fact,
in a C# program, I select based on the second word and I get the first
back. I can compare them and they are obviously different because they
are not even the same length. There must be a bug in the Access
indexing hash routine. Is there any way for me to change the behavior
of the index? Has anyone see anything like this?

-John
Nov 12 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
TC
Remember that Access indexing is case independent (so the presence of "abc"
will prevent the addition of "ABC"). Is it anything to do with that?

HTH,
TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:g7********************************@4ax.com...
I have an Access table that just consists of 2 columns: WordID
(Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've
used this with a number of texts and languages without any problems.
With my first Unicode Greek text, I've encountered a problem. The
first 2 words of the text are "o(doi\ du/o". Now, those obviously are
not the same words, but after I add the first, the second cannot be
added because it thinks that I am making a duplicate entry. In fact,
in a C# program, I select based on the second word and I get the first
back. I can compare them and they are obviously different because they
are not even the same length. There must be a bug in the Access
indexing hash routine. Is there any way for me to change the behavior
of the index? Has anyone see anything like this?

-John

Nov 12 '05 #2

P: n/a
"TC" <a@b.c.d> wrote:
Remember that Access indexing is case independent (so the presence of "abc"
will prevent the addition of "ABC"). Is it anything to do with that?

No, the letters are different. The one word is "odio" and the other
"duo"--the words do not even have the same length!


"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:g7********************************@4ax.com.. .
I have an Access table that just consists of 2 columns: WordID
(Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've
used this with a number of texts and languages without any problems.
With my first Unicode Greek text, I've encountered a problem. The
first 2 words of the text are "o(doi\ du/o". Now, those obviously are
not the same words, but after I add the first, the second cannot be
added because it thinks that I am making a duplicate entry. In fact,
in a C# program, I select based on the second word and I get the first
back. I can compare them and they are obviously different because they
are not even the same length. There must be a bug in the Access
indexing hash routine. Is there any way for me to change the behavior
of the index? Has anyone see anything like this?

-John


Nov 12 '05 #3

P: n/a
This is probably too techie for me as it may well involve code pages or
such but on my UK A2002 setup i have no problem with entering both words.
In fact I can do the following entries.

The entries are

ID WordText
1 o(doi\
2 du/o
3 odoi
4 duo

Regards

Peter Russell
John Baima previously wrote:
"TC" <a@b.c.d> wrote:
Remember that Access indexing is case independent (so the presence of

"abc"
will prevent the addition of "ABC"). Is it anything to do with that?


No, the letters are different. The one word is "odio" and the other
"duo"--the words do not even have the same length!
are not even the same length. There must be a bug in the Access
indexing hash routine. Is there any way for me to change the behavior
of the index? Has anyone see anything like this?

-John



Nov 12 '05 #4

P: n/a
TC
Is it anything to do with two letters being treated as one? (eg. oe in
english) - diacritics, or something?

The other respondent says that he can do it. Are you sure there isn't
another unique index on some other field in the table?

TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:bv********************************@4ax.com...
"TC" <a@b.c.d> wrote:
Remember that Access indexing is case independent (so the presence of "abc"will prevent the addition of "ABC"). Is it anything to do with that?


No, the letters are different. The one word is "odio" and the other
"duo"--the words do not even have the same length!


"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:g7********************************@4ax.com.. .
I have an Access table that just consists of 2 columns: WordID
(Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've
used this with a number of texts and languages without any problems.
With my first Unicode Greek text, I've encountered a problem. The
first 2 words of the text are "o(doi\ du/o". Now, those obviously are
not the same words, but after I add the first, the second cannot be
added because it thinks that I am making a duplicate entry. In fact,
in a C# program, I select based on the second word and I get the first
back. I can compare them and they are obviously different because they
are not even the same length. There must be a bug in the Access
indexing hash routine. Is there any way for me to change the behavior
of the index? Has anyone see anything like this?

-John

Nov 12 '05 #5

P: n/a
Some of the hash tables were messed up in ACC2K (more properly, in the Jet
Engine); I had a similar problem with the traditional Chinese sort order.

In Tools -> Options -> General, what sort order do you have selected? And
what language version of Windows are you using?
"TC" <a@b.c.d> wrote in message news:1065931392.729812@teuthos...
Is it anything to do with two letters being treated as one? (eg. oe in
english) - diacritics, or something?

The other respondent says that he can do it. Are you sure there isn't
another unique index on some other field in the table?

TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:bv********************************@4ax.com...
"TC" <a@b.c.d> wrote:
Remember that Access indexing is case independent (so the presence of "abc"will prevent the addition of "ABC"). Is it anything to do with that?


No, the letters are different. The one word is "odio" and the other
"duo"--the words do not even have the same length!


"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:g7********************************@4ax.com.. .
> I have an Access table that just consists of 2 columns: WordID
> (Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've
> used this with a number of texts and languages without any problems.
> With my first Unicode Greek text, I've encountered a problem. The
> first 2 words of the text are "o(doi\ du/o". Now, those obviously are
> not the same words, but after I add the first, the second cannot be
> added because it thinks that I am making a duplicate entry. In fact,
> in a C# program, I select based on the second word and I get the first> back. I can compare them and they are obviously different because they> are not even the same length. There must be a bug in the Access
> indexing hash routine. Is there any way for me to change the behavior
> of the index? Has anyone see anything like this?
>
> -John


Nov 12 '05 #6

P: n/a
TC
Sorry, can not answer your second question - I don't have Access on this PC!

Note it was the other respondent who said he could do it - not me.

TC
"Bruce Rusk" <ho**********@spamless.ucla.edu> wrote in message
news:bm**********@gladiola.noc.ucla.edu...
Some of the hash tables were messed up in ACC2K (more properly, in the Jet
Engine); I had a similar problem with the traditional Chinese sort order.

In Tools -> Options -> General, what sort order do you have selected? And
what language version of Windows are you using?
"TC" <a@b.c.d> wrote in message news:1065931392.729812@teuthos...
Is it anything to do with two letters being treated as one? (eg. oe in
english) - diacritics, or something?

The other respondent says that he can do it. Are you sure there isn't
another unique index on some other field in the table?

TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:bv********************************@4ax.com...
"TC" <a@b.c.d> wrote:
>Remember that Access indexing is case independent (so the presence of

"abc"
>will prevent the addition of "ABC"). Is it anything to do with that?
>

No, the letters are different. The one word is "odio" and the other
"duo"--the words do not even have the same length!

>
>
>"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
>news:g7********************************@4ax.com.. .
>> I have an Access table that just consists of 2 columns: WordID
>> (Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've >> used this with a number of texts and languages without any problems. >> With my first Unicode Greek text, I've encountered a problem. The
>> first 2 words of the text are "o(doi\ du/o". Now, those obviously are >> not the same words, but after I add the first, the second cannot be
>> added because it thinks that I am making a duplicate entry. In fact, >> in a C# program, I select based on the second word and I get the first >> back. I can compare them and they are obviously different because they >> are not even the same length. There must be a bug in the Access
>> indexing hash routine. Is there any way for me to change the behavior >> of the index? Has anyone see anything like this?
>>
>> -John
>



Nov 12 '05 #7

P: n/a
I'm using Windows XP Pro with US-English. In Tools | Options |
General, for "New Database sort order" I have "General".

The problem is that Access is ignoring the "Extended Greek" in the
\U80xx code page. The Greek characters in the \U09xx code page are
included. The two words I had a problem with were:

\u8001\u948\u959\u8054

\u948\u8059\u959

Access will not allow you to enter \u948\u959 either. Is there any
workaround for this?

BTW, I think that this problem also shows in SQL Server as well.

"Bruce Rusk" <ho**********@spamless.ucla.edu> wrote:
Some of the hash tables were messed up in ACC2K (more properly, in the Jet
Engine); I had a similar problem with the traditional Chinese sort order.

In Tools -> Options -> General, what sort order do you have selected? And
what language version of Windows are you using?
"TC" <a@b.c.d> wrote in message news:1065931392.729812@teuthos...
Is it anything to do with two letters being treated as one? (eg. oe in
english) - diacritics, or something?

The other respondent says that he can do it. Are you sure there isn't
another unique index on some other field in the table?

TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:bv********************************@4ax.com...
> "TC" <a@b.c.d> wrote:
> >Remember that Access indexing is case independent (so the presence of

"abc"
> >will prevent the addition of "ABC"). Is it anything to do with that?
> >
>
> No, the letters are different. The one word is "odio" and the other
> "duo"--the words do not even have the same length!
>
> >
> >
> >"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
> >news:g7********************************@4ax.com.. .
> >> I have an Access table that just consists of 2 columns: WordID
> >> (Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've
> >> used this with a number of texts and languages without any problems.
> >> With my first Unicode Greek text, I've encountered a problem. The
> >> first 2 words of the text are "o(doi\ du/o". Now, those obviously are
> >> not the same words, but after I add the first, the second cannot be
> >> added because it thinks that I am making a duplicate entry. In fact,
> >> in a C# program, I select based on the second word and I get thefirst > >> back. I can compare them and they are obviously different becausethey > >> are not even the same length. There must be a bug in the Access
> >> indexing hash routine. Is there any way for me to change the behavior
> >> of the index? Has anyone see anything like this?
> >>
> >> -John
> >
>



John Baima
Nov 12 '05 #8

P: n/a
TC
There are a few people who would definitely know the answer to this. It
surprises me that they haven't replied. Perhaps repost your question in a
new thread in a day or two. Personally, as soon as I see the words "code
page", my eyes glaze over, & I start to tremble uncontrollably...

TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:5a********************************@4ax.com...
I'm using Windows XP Pro with US-English. In Tools | Options |
General, for "New Database sort order" I have "General".

The problem is that Access is ignoring the "Extended Greek" in the
\U80xx code page. The Greek characters in the \U09xx code page are
included. The two words I had a problem with were:

\u8001\u948\u959\u8054

\u948\u8059\u959

Access will not allow you to enter \u948\u959 either. Is there any
workaround for this?

BTW, I think that this problem also shows in SQL Server as well.

"Bruce Rusk" <ho**********@spamless.ucla.edu> wrote:
Some of the hash tables were messed up in ACC2K (more properly, in the JetEngine); I had a similar problem with the traditional Chinese sort order.

In Tools -> Options -> General, what sort order do you have selected? And
what language version of Windows are you using?
"TC" <a@b.c.d> wrote in message news:1065931392.729812@teuthos...
Is it anything to do with two letters being treated as one? (eg. oe in
english) - diacritics, or something?

The other respondent says that he can do it. Are you sure there isn't
another unique index on some other field in the table?

TC
"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
news:bv********************************@4ax.com...
> "TC" <a@b.c.d> wrote:
> >Remember that Access indexing is case independent (so the presence of "abc"
> >will prevent the addition of "ABC"). Is it anything to do with that?
> >
>
> No, the letters are different. The one word is "odio" and the other
> "duo"--the words do not even have the same length!
>
> >
> >
> >"John Baima" <jo**@REMOVEME.silvershot.com> wrote in message
> >news:g7********************************@4ax.com.. .
> >> I have an Access table that just consists of 2 columns: WordID
> >> (Autonumber, Primary key) and WordText (Text, Indexed, No dups). I've > >> used this with a number of texts and languages without any problems. > >> With my first Unicode Greek text, I've encountered a problem. The
> >> first 2 words of the text are "o(doi\ du/o". Now, those obviously are > >> not the same words, but after I add the first, the second cannot be > >> added because it thinks that I am making a duplicate entry. In fact, > >> in a C# program, I select based on the second word and I get the

first
> >> back. I can compare them and they are obviously different because

they
> >> are not even the same length. There must be a bug in the Access
> >> indexing hash routine. Is there any way for me to change the behavior > >> of the index? Has anyone see anything like this?
> >>
> >> -John
> >
>


John Baima

Nov 12 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.