By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,045 Members | 1,760 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,045 IT Pros & Developers. It's quick & easy.

Make Reports Open 100%

P: n/a
I have many reports in my database. All but one opens at 100%. The one opens at
"Fit". How do I make that one open at 100%?

Thanks for all help!

Steve
Nov 12 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
I was able to get it to do so by placing the following in the Detail Section's OnRetreat
event.

RunCommand acCmdZoom100

--
Wayne Morgan
"Steve" <ss****@bellsouth.net> wrote in message
news:KZ*****************@newsread1.news.atl.earthl ink.net...
I have many reports in my database. All but one opens at 100%. The one opens at
"Fit". How do I make that one open at 100%?

Nov 12 '05 #2

P: n/a
ps.

This Retreat event is the only one that I found that would accept the command. The trick
is that the Retreat event may not be triggered depending on what you're doing. All the
other events on the report or its sections gave me an error that said the command can't be
run at this time. However, with further testing, I found that if I placed the RunCommand
acCmdZoom100 command right after the DoCmd.OpenReport call, that it appeared to work every
time.

--
Wayne Morgan
"Steve" <ss****@bellsouth.net> wrote in message
news:KZ*****************@newsread1.news.atl.earthl ink.net...
I have many reports in my database. All but one opens at 100%. The one opens at
"Fit". How do I make that one open at 100%?

Thanks for all help!

Steve

Nov 12 '05 #3

P: n/a
Wayne,

Thanks for responding!

I didn't have to do this for any of the other reports and they all open at 100%.
Why would I have to do it for this report?

Steve
"Wayne Morgan" <co***************************@hotmail.com> wrote in message
news:Cs*****************@newssvr33.news.prodigy.co m...
ps.

This Retreat event is the only one that I found that would accept the command. The trick is that the Retreat event may not be triggered depending on what you're doing. All the other events on the report or its sections gave me an error that said the command can't be run at this time. However, with further testing, I found that if I placed the RunCommand acCmdZoom100 command right after the DoCmd.OpenReport call, that it appeared to work every time.

--
Wayne Morgan
"Steve" <ss****@bellsouth.net> wrote in message
news:KZ*****************@newsread1.news.atl.earthl ink.net...
I have many reports in my database. All but one opens at 100%. The one opens at "Fit". How do I make that one open at 100%?

Thanks for all help!

Steve


Nov 12 '05 #4

P: n/a
"Steve" <ss****@bellsouth.net> wrote in message
news:E9****************@newsread2.news.atl.earthli nk.net...
Wayne,

Thanks for responding!

I didn't have to do this for any of the other reports and they all open at 100%.
Why would I have to do it for this report?


Did you develop this app? IME reports always open at 100% unless there is code added
to make them do otherwise. Are you sure this one doesn't have that? Is the result
the same when you open from the db window as opposed to using a command button to
open it?
Nov 12 '05 #5

P: n/a
Rick,

Thanks for the comments!

Yes, it opens in "Fit" from the database window too.

Steve
"Rick Brandt" <ri*********@hotmail.com> wrote in message
news:bl************@ID-98015.news.uni-berlin.de...
"Steve" <ss****@bellsouth.net> wrote in message
news:E9****************@newsread2.news.atl.earthli nk.net...
Wayne,

Thanks for responding!

I didn't have to do this for any of the other reports and they all open at 100%. Why would I have to do it for this report?
Did you develop this app? IME reports always open at 100% unless there is

code added to make them do otherwise. Are you sure this one doesn't have that? Is the result the same when you open from the db window as opposed to using a command button to open it?

Nov 12 '05 #6

P: n/a
On Thu, 02 Oct 2003 14:05:26 GMT in comp.databases.ms-access, "Steve"
<ss****@bellsouth.net> wrote:
Rick,

Thanks for the comments!

Yes, it opens in "Fit" from the database window too.


I can't find a pattern to this, my scratch cdma database had but one
report, it opened in "Fit". I created a new report (using "columnar
wizard") and it opened in "100%", I save it, closed it, opened it
again and it opened in "Fit". Balmy.

In my live apps, I generally have a profile set for preferred view and
use the method that Wayne posted so I never really noticed it before.

--
A)bort, R)etry, I)nfluence with large hammer.
Nov 12 '05 #7

P: n/a
Rick,

I've found that to usually be the case, but I have a few that don't also. I haven't been
able to pin down a common cause yet. If I go from design view to preview it opens at 100%,
if I open it from the database window it opens at Fit. I didn't notice this in earlier
versions of Access, but XP seems to like to do this.

I just did some more playing around. It appears that if I turn Auto Resize off in the
report's properties that it opens at 100%, if Auto Resize is on, it opens at Fit.

--
Wayne Morgan
"Rick Brandt" <ri*********@hotmail.com> wrote in message
news:bl************@ID-98015.news.uni-berlin.de...
"Steve" <ss****@bellsouth.net> wrote in message
news:E9****************@newsread2.news.atl.earthli nk.net...
Did you develop this app? IME reports always open at 100% unless there is code added
to make them do otherwise. Are you sure this one doesn't have that? Is the result
the same when you open from the db window as opposed to using a command button to
open it?

Nov 12 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.