By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,773 Members | 2,583 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,773 IT Pros & Developers. It's quick & easy.

Access97 to Oracle8i odbc-problem (SQLSetConnectAttr failed)

P: n/a
In an Access97 application I fetch data from an Oracle database via a
linked table (via Odbc/sqlnet). The Oracle database now upgrades from
7.3 to 8.0. The Oracle odbc driver I use (2.0.3.1, supplied with 7.3)
always worked fine on all Nt4 workstations. Now with the 8.0 db an
odbc error occurs when the db is contacted: [Oracle]{ODBC Oracle
Driver][Oracle OCI]ORA-01034: ORACLE not available. (#1034)
[Microsoft][ODBC-Driver Manager] SQLSetConnectAttr of the device
driver had failed.

On a standard win2000 pc, and a Xp pc everything works fine. One
tested Nt4 workstation it works fine... but on the others it won't. I
already tried installing different Mdac's, 2 different Oracle odbc
drivers, and read a few Ms-KBase articles about related problems, but
the problem is still there. Can't tell the difference between the one
Nt4 pc that functions allright and the others. Does someone have a
hint ??
I will try to use the odbc-driver for Oracle 8i (in the hope that will
work) but it would be much easier in my situation if an older driver
that's also userd for 7.3 databases could be used (and it can work
allright as proven on the one pc!).

In http://support.microsoft.com/default...NoWebContent=1
I found that the problem might be the fact that it's just an
informational message that may be ignored. Okay when scripting via ADO
but how to deal with it when using Access linked tables ?
Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.