By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,940 Members | 611 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,940 IT Pros & Developers. It's quick & easy.

OLE Object Linking

P: n/a
Tom
Access97

I have an Excel worksheet that contains seven graphs. In my application I have
seven subreports in an unbound report. In each subreport I Paste-Linked one of
the graphs in the Excel worksheet. When I look at the Data tab for each unbound
object frame, the properties are all complete. I have a routine that does the
following:
1. Use TransferSpreadsheet seven times to export data into seven named ranges
where each range is the data source for one of the graphs
2. Open a pop-up form in acdialog mode for the user to add some text to the
title page of the main report
3. Open the main report with the seven subreports in preview mode

The graphs in the unbound object frames do not update for the data that was
exported in Step 1.

I tried the following in the On Open event of each subreport:
Ole1.Action = acOleUpdate
and I get an error message that OLE1 does not contain an OLE object.

Two questions:
1. How do I get the graphs in the unbound object frames to update?
2. Why aren't the graphs in the unbound object frames OLE objects when I
paste-linked them there from an Excel worksheet?

Thanks!

Tom


Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.