By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,863 Members | 879 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,863 IT Pros & Developers. It's quick & easy.

Sub Report Name Displaying Instead Of Data

P: n/a
I have a database that is used for tracking customer survey data. Each
customer can have multiple products. I have a report that lists customers
that have not yet been surveyed )(rptCustomersNotSurveyed), and another
report that lists the customers that have been surveyed
(rptCustomersSurveyed). A survey can be done for each product, since many
times there are different contact people at the customer for each product.
Within rptCustomersNotSurveyed, for each customer I would like to show a
subreport that shows the surveys that have been completed for other products
for that customer. Each customer has a unique identifying field (lawsonID)
that is used to link the subreport to teh main report.

The problem I'm having is that instead of getting the data in the subreport,
I get the subreport name displayed in rptCustomersNotSurveyed. I've tried
to link the reports two different ways (using the subreport wizard): by
creating a report for the subreport and linkg that to
rptCustomersNotSurveyed, and by using the underlying query for
rptCustomersSurveyed. Either way, just get the name of the subreport
instead of the data. In addition, when I run the underlying query for
rptCustomersSurveyed and the report by themselves, they work fine.

Does anybody have an idea where the problem could lie?

Thanks.

Steve

Nov 12 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.